Bug 75075 - Remove web deployment descriptor APIs
Remove web deployment descriptor APIs
Status: RESOLVED DUPLICATE of bug 71288
Product: javaee
Classification: Unclassified
Component: DD Editor
5.x
All All
: P2 (vote)
: 5.x
Assigned To: apireviews
issues@javaee
: API, API_REVIEW_FAST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-14 17:15 UTC by Petr Jiricka
Modified: 2006-04-24 08:45 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2006-04-14 17:15:05 UTC
I would like to remove the Web Deployment Descriptor API from the standard
distribution of NetBeans 5.5:

http://www.netbeans.org/download/dev/javadoc/org-netbeans-api-web-dd/architecture-summary.html
http://www.netbeans.org/download/dev/javadoc/org-netbeans-api-web-dd/overview-summary.html

This API was deprecated (it is not listed in the API list for NB 5.0), and
replaced by the J2EE deployment descriptor API, which handles all J2EE
deployment descriptors (not just web tier):

http://www.netbeans.org/download/dev/javadoc/org-netbeans-modules-j2ee-dd/architecture-summary.html
http://www.netbeans.org/download/dev/javadoc/org-netbeans-modules-j2ee-dd/overview-summary.html

Currently we are not aware of any clients that use the deprecated web dd API.
Comment 1 Petr Jiricka 2006-04-24 08:45:51 UTC
Done, per issue 71288. Marking as a duplicate of that issue.

*** This issue has been marked as a duplicate of 71288 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo