Bug 74855 - Add an API for opening the Options dialog
Add an API for opening the Options dialog
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
5.x
All All
: P2 (vote)
: 6.x
Assigned To: rmatous
issues@platform
plan60
: API, API_REVIEW_FAST
: 64350 (view as bug list)
Depends on:
Blocks: 64350 75856 91331
  Show dependency treegraph
 
Reported: 2006-04-11 14:52 UTC by Sherold Dev
Modified: 2008-12-22 21:31 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Suggested API + test (13.97 KB, text/plain)
2006-12-13 11:47 UTC, rmatous
Details
modified according to comments (14.35 KB, text/plain)
2006-12-14 10:41 UTC, rmatous
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sherold Dev 2006-04-11 14:52:00 UTC
Add an API for opening the Options dialog. Being able to specify the category
that should be preselected would be desirable.

Currently there are several places from where you can edit proxy settings:
auto-update, web services client wizard, cvs support and each from this places
uses its own proxy setting dialog even if there is already one in the Options
dialog.

We would like to allow to set the proxy parameters also from the server
customizers in the server manager, but since we do not want to introduce new
instances of proxy form dialogs we would like to open the proxy form in the
Options dialog instead.
Comment 1 rmatous 2006-12-07 14:03:40 UTC
*** Issue 64350 has been marked as a duplicate of this issue. ***
Comment 2 rmatous 2006-12-13 11:47:45 UTC
Created attachment 36638 [details]
Suggested API + test
Comment 3 Jesse Glick 2006-12-13 16:04:13 UTC
Not clear what the call to SwingUtilities.invokeAndWait is good for, if you are
anyway using Mutex.EVENT.readAccess. If you do need this call, please document
that fact, since it is dangerous (deadlock-prone).


Boolean retval = Mutex.EVENT.readAccess(new Mutex.Action<Boolean> () {
  public Boolean run() {
    // ...
    return Boolean.valueOf(retvalForRun);
  }
});
return retval;

can be simplified to

return Mutex.EVENT.readAccess(new Mutex.Action<Boolean> () {
  public Boolean run() {
    // ...
    return retvalForRun;
  }
});


Missing @since and spec vers increment.
Comment 4 Vitezslav Stejskal 2006-12-13 18:52:03 UTC
I don't think Logger.log() methods permit passing null as the msg parameter.
Comment 5 Jesse Glick 2006-12-13 19:12:13 UTC
log.log(Level.SEVERE, null, ex);

is fine (check LogRecord constructor), though it is a bit easier to call
Exceptions.printStackTrace.
Comment 6 rmatous 2006-12-14 10:41:38 UTC
Created attachment 36663 [details]
modified according to comments
Comment 7 rmatous 2006-12-19 15:00:25 UTC
/cvs/core/options/src/org/netbeans/modules/options/Utils.java,v  <--  Utils.java
new revision: 1.6; previous revision: 1.5

/cvs/core/options/src/org/netbeans/modules/options/OptionsPanel.java,v  <--  new
revision: 1.40; previous revision: 1.39

/cvs/core/options/src/org/netbeans/modules/options/OptionsDisplayerImpl.java,v 
initial revision: 1.1

/cvs/core/options/src/org/netbeans/modules/options/CategoryModel.java,v  <-- 
new revision: 1.4; previous revision: 1.3

/cvs/core/options/src/org/netbeans/modules/options/OptionsWindowAction.java,v 
new revision: 1.34; previous revision: 1.33

/cvs/core/options/apichanges.xml,v  <--  apichanges.xml
new revision: 1.5; previous revision: 1.4

/cvs/core/options/manifest.mf,v  <--  manifest.mf
new revision: 1.9; previous revision: 1.8

/cvs/core/options/test/unit/src/org/netbeans/api/options/OptionsDisplayerOpenTest.java,v
 initial revision: 1.1

/cvs/core/options/test/unit/src/org/netbeans/api/options/RegisteredCategory.java,v
 initial revision: 1.1

/cvs/core/options/test/unit/src/org/netbeans/api/options/mf-layer.xml,v  <-- 
initial revision: 1.1

/cvs/core/options/test/unit/src/org/netbeans/api/options/IDEInitializer.java,v 
initial revision: 1.1

/cvs/core/options/test/build.xml,v  <--  build.xml
initial revision: 1.1

/cvs/core/options/test/cfg-unit.xml,v  <--  cfg-unit.xml
initial revision: 1.1

/cvs/core/options/test/build-unit.xml,v  <--  build-unit.xml
initial revision: 1.1

/cvs/core/options/src/org/netbeans/api/options/OptionsDisplayer.java,v  <-- 
initial revision: 1.1

/cvs/core/options/nbproject/project.properties,v  <--  project.properties
new revision: 1.8; previous revision: 1.7

/cvs/core/options/nbproject/project.xml,v  <--  project.xml
new revision: 1.9; previous revision: 1.8

/cvs/ide/golden/public-packages.txt,v  <--  public-packages.txt
new revision: 1.78; previous revision: 1.77

/cvs/core/options/src/org/netbeans/modules/options/advanced/Model.java,v  <-- 
new revision: 1.14; previous revision: 1.13

/cvs/core/options/src/org/netbeans/modules/options/ui/TabbedPanel.java,v  <-- 
new revision: 1.8; previous revision: 1.7



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo