Bug 74766 - I18N - switching between locales problems
I18N - switching between locales problems
Status: RESOLVED DUPLICATE of bug 42638
Product: platform
Classification: Unclassified
Component: Filesystems
6.x
All Windows ME/2000
: P2 (vote)
: TBD
Assigned To: rmatous
issues@platform
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 08:27 UTC by Pavel Rehak
Modified: 2008-12-22 11:52 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (120.93 KB, image/jpeg)
2006-04-11 08:28 UTC, Pavel Rehak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Rehak 2006-04-11 08:27:50 UTC
NetBeans IDE Dev (Build 200604101800)
1.5.0_06; Java HotSpot(TM) Client VM 1.5.0_06-b05
Windows XP version 5.1 running on x86
cs_CZ (nb); Cp1250
----
I used (for previous builds) pseudolokalized nb5.5 on windows
with jappanise locales for testing purposes, currently i switched
to trunk dev version and turned back to my czech locales.
i've opened project changed under localized nb and
have troubles with multibyte characters in editor and output
window 
(see attachment)
when i try to clean/build this project it fails 
in message.log:
SEVERE [null]: getCanonicalFile() on file
F:\my_work\anotherTest\anotherTest\src\??renamed.java failed.
java.io.IOException: The system cannot find the file specified

but my system itself have no problems reading multibyte characters,
even in project view i can see file name properly and even in editor
i can copy paste new multibyte characters.
only interpretation of characters comming from java file system is wierd.
Comment 1 Pavel Rehak 2006-04-11 08:28:53 UTC
Created attachment 29747 [details]
screenshot
Comment 2 Marian Petras 2006-06-28 12:44:05 UTC
The described problems are mostly caused by the fact that the source code editor
and the compiler do not know which encoding to use for displaying and compiling
the file. Most probably both the editor and the compiler use the default
encoding for the current locale. If the encoding it specified for Java source
files (in the Options dialog), the files are displayed correctly. The same is
probably true for the compiler - it must be set in the project's properties.

It may also happen that the multibyte characters are not properly rendered in
the IDE - this is a matter of the JDK whether it uses the appropriate fonts.

None of these issues can be fixed or otherwise influenced by the I18n module -
reassigned to (pseudo-)module IDE for further dispatch.
Comment 3 Ken Frank 2006-07-13 23:19:44 UTC
if the encoding for the java files is changed to the ja or utf8 one
when you are in cz locale,
 does it work or still problems
in showing the ja characters created when in ja locale.

I realize that the ide does not have any universal kind of encoding
detection, but wondering, if utf8 used when in ja locale, then make
sure its used when in cz locale, does it help.

for the compiler, however, is there an option for that just like there is for
editor ?

ken.frank@sun.com
Comment 4 rmatous 2007-01-09 16:02:41 UTC
#42638 necessary for fixing this sort of problems

*** This issue has been marked as a duplicate of 42638 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo