Bug 74558 - "Customize Toolbars" hangs NetBeans IDE
"Customize Toolbars" hangs NetBeans IDE
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: RANDOM, THREAD
: 80713 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 03:36 UTC by rrochat
Modified: 2008-12-22 20:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Full thread dump (10.65 KB, text/plain)
2006-04-07 03:38 UTC, rrochat
Details
log file (177.97 KB, text/plain)
2006-04-07 03:39 UTC, rrochat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rrochat 2006-04-07 03:36:21 UTC
I can't give you an exact sequence of steps to reproduce, but 3 times now today
I've had NetBeans hang while using the Customize Toolbars dialog after adding a
new toolbar and dropping actions in it.  I finally got it to hang with the
command window open, so am attaching the dump and my log file.
Comment 1 rrochat 2006-04-07 03:38:21 UTC
Created attachment 29682 [details]
Full thread dump
Comment 2 rrochat 2006-04-07 03:39:59 UTC
Created attachment 29683 [details]
log file
Comment 3 Stanislav Aubrecht 2006-04-10 16:11:37 UTC
from the stack trace i can see where the deadlock is happening but i had no luck
reproducing it so far
Comment 4 rrochat 2006-04-12 23:00:36 UTC
I deleted the Toolbars folder in my config userdir, brought up NetBeans 5.0,
right clicked on the Toolbar, executed "Customize Toolbars", clicked the "New
Toolbar" button, typed "asdf" as the name, and it hung.
Then I tried the exact same sequence again and it worked fine.
Sometimes I can get it to hang easily (always after typing in a new toolbar
name), and other times I can create 20 toolbars in a row with no trouble.
If you want the new thread dump, I can attach it, but it looked like the same
thing to me:
"FolderChildren_Refresh" daemon prio=2 tid=0x11d43160 nid=0x578 waiting for moni
tor entry [0x116cf000..0x116cf9e8]
        at java.awt.Component.addPropertyChangeListener(Component.java:7001)
        - waiting to lock <0x03f1b1c8> (a org.openide.awt.ToolbarPool)
        at java.awt.Container.addPropertyChangeListener(Container.java:3373)
        at org.netbeans.core.windows.services.ToolbarFolderNode$ToolbarNode.<ini
t>(ToolbarFolderNode.java:410)
Comment 5 Stanislav Aubrecht 2006-07-27 11:29:13 UTC
*** Issue 80713 has been marked as a duplicate of this issue. ***
Comment 6 Stanislav Aubrecht 2006-08-01 10:18:16 UTC
fixed in trunk

Checking in DefaultSettings.java;
/cvs/core/palette/src/org/netbeans/modules/palette/DefaultSettings.java,v  <-- 
DefaultSettings.java
new revision: 1.10; previous revision: 1.9
done
Comment 7 Stanislav Aubrecht 2006-08-01 10:34:17 UTC
sorry, the previous comment has actually nothing to do with this issue - pls
disregard it.
Comment 8 Stanislav Aubrecht 2006-08-02 10:48:42 UTC
fixed in trunk

Checking in ToolbarFolderNode.java;
/cvs/core/windows/src/org/netbeans/core/windows/services/ToolbarFolderNode.java,v
 <--  ToolbarFolderNode.java
new revision: 1.16; previous revision: 1.15
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo