Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 74465 - tables not refreshed after new one added in execute sql
tables not refreshed after new one added in execute sql
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
5.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
:
: 90050 (view as bug list)
Depends on:
Blocks: 152816
  Show dependency treegraph
 
Reported: 2006-04-05 21:59 UTC by Rochelle Raccah
Modified: 2013-02-14 20:40 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rochelle Raccah 2006-04-05 21:59:45 UTC
In the runtime explorer, connect to a db.  Expand the list of tables.  Now click
on the connection and execute sql.  In the editor, put a create table statement,
then execute it.  The output window shows no errors, the new table is in the db,
but the tables node in the explorer doesn't show the new one.

Workaround: disconnect and reconnect the db connection node.
Comment 1 Andrei Badea 2006-04-07 10:12:33 UTC
Since the SQL editor is in another module than db, this would need some kind of
API. Probably the db/dbapi module in issue 74329 could be used for this.
Comment 2 Andrei Badea 2006-05-29 14:16:24 UTC
It is not necessary to reconnect, you can just invoke the Refresh action on the
Tables node.
Comment 3 Andrei Badea 2006-11-27 09:38:10 UTC
*** Issue 90050 has been marked as a duplicate of this issue. ***
Comment 4 David Vancouvering 2008-03-22 00:57:06 UTC
Sorry, I don't see this as a bug but as a feature request - one that would be really nice, but still a feature request.
Comment 5 Jiri Rechtacek 2009-10-16 14:13:01 UTC
Reassigned to new owner.
Comment 6 matthias42 2013-02-14 20:40:43 UTC
Tested in netbeans 7.2.1 - and works there - the node tree is reloaded on change.

The refresh could be nicer (the whole database node is collapsed), but it works.

Tested with create and drop table statement.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo