Bug 74391 - Jackpot broken - linkage error
Jackpot broken - linkage error
Status: RESOLVED DUPLICATE of bug 74344
Product: contrib
Classification: Unclassified
Component: Jackpot
5.x
All All
: P1 (vote)
: TBD
Assigned To: _ tball
issues@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 17:10 UTC by Jesse Glick
Modified: 2006-04-04 21:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2006-04-04 17:10:09 UTC
I upgraded to the latest Jackpot and compiler modules available on dev AU:

org.netbeans.libs.javacapi [0.2.1.1 1 060402]
org.netbeans.libs.javacimpl [0.2.2 2 060402]
org.netbeans.jackpot [1.2.8.2 2 060402]
org.netbeans.modules.jackpot/1 [1.2.5.2 2 060402]
org.netbeans.modules.jackpot.rules [1.2.3.3 3 060402]

Now when I try to run a rule I just get

org.netbeans.jackpot.engine.EngineException: Error executing operator
	at org.netbeans.jackpot.builder.Engine.runScript(Engine.java:160)
[catch] at
org.netbeans.modules.jackpot.JackpotModule.runCommand(JackpotModule.java:131)
	at
org.netbeans.modules.jackpot.actions.JackpotAction$CommandRunner.run(JackpotAction.java:81)
	at java.lang.Thread.run(Thread.java:618)
Caused by: java.lang.NoSuchMethodError:
com.sun.source.tree.CompilationUnitTree.getPackageDecl()Lcom/sun/source/tree/ExpressionTree;
	at
org.netbeans.jackpot.transform.ImmutableTreeTranslator.rewriteChildren(ImmutableTreeTranslator.java:405)
	at
org.netbeans.jackpot.transform.ImmutableTreeTranslator.visitCompilationUnit(ImmutableTreeTranslator.java:236)
	at
org.netbeans.jackpot.transform.ImmutableTreeTranslator.visitCompilationUnit(ImmutableTreeTranslator.java:46)
	at com.sun.tools.javac.tree.JCTree$JCCompilationUnit.accept(JCTree.java:474)
	at
org.netbeans.jackpot.transform.ImmutableTreeTranslator.translate(ImmutableTreeTranslator.java:69)
...
Comment 1 _ tball 2006-04-04 17:49:29 UTC
Did you just upgrade to Mustang build 78?  I just got another report, 74344,
this morning regarding that with a similar stacktrace to another missing method.  
Comment 2 Jesse Glick 2006-04-04 19:34:51 UTC
I am using b78 but I think I observed it also in an IDE running on JDK 5 (not
positive, can double-check if you need me to).
Comment 3 _ tball 2006-04-04 21:14:51 UTC
It's an API incompatibility between Mustang b75 and b78.  I'd be really
surprised if you see it with Java 5, unless you have the Mustang b78 tools.jar
in your classpath.

diff CompilationUnitTree.java-b75 com/sun/source/tree/CompilationUnitTree.java
2c2
<  * @(#)CompilationUnitTree.java       1.2 05/11/17
---
>  * @(#)CompilationUnitTree.java       1.3 06/03/14
27,28c27,28
<     ExpressionTree getPackageDecl();
<     List<? extends ImportTree> getImportDecls();
---
>     ExpressionTree getPackageName();
>     List<? extends ImportTree> getImports();
Comment 4 _ tball 2006-04-04 21:44:33 UTC

*** This issue has been marked as a duplicate of 74344 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo