Bug 7435 - Module 'all' is missing some sub-modules
Module 'all' is missing some sub-modules
Status: RESOLVED INVALID
Product: obsolete
Classification: Unclassified
Component: collabnet
3.x
PC Linux
: P1 (vote)
: TBD
Assigned To: support
issues@www
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-20 12:47 UTC by jskov
Modified: 2009-11-08 02:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Patch to CVSROOT/modules from 1.37 version (8.01 KB, patch)
2000-08-29 10:48 UTC, Jesse Glick
Details | Diff
Newer patch to CVSROOT/modules from 1.37 (10.74 KB, patch)
2000-10-11 15:44 UTC, Jesse Glick
Details | Diff
Newer diff, incl. changes to cvsignore and cvswrappers (11.65 KB, patch)
2000-10-26 15:03 UTC, Jesse Glick
Details | Diff
Yet a newer diff (16.24 KB, patch)
2000-11-06 20:02 UTC, Jesse Glick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jskov 2000-08-20 12:47:28 UTC
Checking out module 'all' is not enough to build the project. The dirs/modules
jarpackager, i18, and nproperties are missing.
Comment 1 Jesse Glick 2000-08-23 16:19:59 UTC
A number of updates to the CVS modules file have been requested but not yet
saved into CVS.
Comment 2 support 2000-08-29 02:04:59 UTC
I setup the CVSROOT/modules file as version 1.36 as per jesse glick's mail
request. However, I ended up having problems with checking out 'apiexamples'
which seemed to have an error. I fixed the problem and checked in a new
1.37 version of 'modules' which no longer has an error.

--------
Subject: CVS update: .
From:    commitlogger@mail.netbeans.org
Date:    29 Aug 2000 00:51:41 -0000
To:      cvs@CVSROOT.netbeans.org
             ----------------------------------------
  User: npm
  Date: 00/08/28 17:51:41

  Modified:    .        modules
  Log:
  In testing 'apiexamples' I got an error:
  > coggie-13-.../COLLAB.NET/netbeans-new-modules-test> cvs co apiexamples
  > cvs server: cannot find module `api_eg_mani_globaloptions' - ignored
  > cvs [checkout aborted]: cannot expand modules

  it turned out api_eg_mani_globaloptions did not exist, but
  api_eg_mani_globalactions did. furthermore, api_eg_mani_globalactions
  wasn't being used anywhere. therefore, i changed
  api_eg_mani_globaloptions --> api_eg_mani_globalactions in an attempt
  at fixing the above error.

  -- Niels Mayer (npm@collab.net)

  Revision  Changes    Path
  1.37      +1 -1      CVSROOT/modules

  (In the diff below, changes in quantity of whitespace are not shown.)

  Index: modules
  ===================================================================
  RCS file: /usr/tigris/tigrisc/repository/CVSROOT/modules,v
  retrieving revision 1.36
  retrieving revision 1.37
  diff -c -b -r1.36 -r1.37
  *** modules   2000/08/28 23:38:17     1.36
  --- modules   2000/08/29 00:51:41     1.37
  ***************
  *** 256,262 ****

    # Open APIs examples, as used by whitepaper:

  ! apiexamples -a api_eg_src_minicomposer api_eg_src_scripts api_eg_src_syspro
ps api_eg_src_serialversion api_eg_src_globalactions api_eg_mani_minicomposer a
pi_eg_mani_sysprops api_eg_mani_serialversion api_eg_mani_globaloptions api_eg_
tojar_minicomposer
    api_eg_src_minicomposer -d apiexamples/org/netbeans/examples/modules/minico
mposer openide/api/examples/org/netbeans/examples/modules/minicomposer
    api_eg_src_scripts -d apiexamples/org/netbeans/examples/scripts openide/api
/examples/org/netbeans/examples/scripts
    api_eg_src_sysprops -d apiexamples/org/netbeans/modules/sysprops sysprops/s
rc/org/netbeans/modules/sysprops
  --- 256,262 ----

    # Open APIs examples, as used by whitepaper:

  ! apiexamples -a api_eg_src_minicomposer api_eg_src_scripts api_eg_src_syspro
ps api_eg_src_serialversion api_eg_src_globalactions api_eg_mani_minicomposer a
pi_eg_mani_sysprops api_eg_mani_serialversion api_eg_mani_globalactions api_eg_
tojar_minicomposer
    api_eg_src_minicomposer -d apiexamples/org/netbeans/examples/modules/minico
mposer openide/api/examples/org/netbeans/examples/modules/minicomposer
    api_eg_src_scripts -d apiexamples/org/netbeans/examples/scripts openide/api
/examples/org/netbeans/examples/scripts
    api_eg_src_sysprops -d apiexamples/org/netbeans/modules/sysprops sysprops/s
rc/org/netbeans/modules/sysprops
Comment 3 Jesse Glick 2000-08-29 10:46:59 UTC
Yes, that was correct--"globaloptions" was a typo, it should have been
"globalactions". Thank you.

Reopening because this bug will never be fixed--as new things are added or
shifted about, CVSROOT/modules will continue to be out of date so long as there
is not direct access to it. I will attach a diff against the new version there.
It need not be applied immediately, because I know it will change further in the
near future anyway.
Comment 4 Jesse Glick 2000-08-29 10:48:59 UTC
Created attachment 115 [details]
Patch to CVSROOT/modules from 1.37 version
Comment 5 Jesse Glick 2000-10-11 15:44:59 UTC
Created attachment 189 [details]
Newer patch to CVSROOT/modules from 1.37
Comment 6 Jesse Glick 2000-10-11 15:46:59 UTC
Please apply CVSROOT/modules patches as attached here when you get a chance.
Thanks, -Jesse
Comment 7 Jesse Glick 2000-10-23 15:17:59 UTC
Please apply the diff. Builds are now broken for people who "cvs co all" because
the build now requires module 'vcscore' which is not mentioned in
CVSROOT/modules without the latest patch.
Comment 8 Jesse Glick 2000-10-26 15:03:59 UTC
Created attachment 209 [details]
Newer diff, incl. changes to cvsignore and cvswrappers
Comment 9 Jesse Glick 2000-11-06 20:02:59 UTC
Created attachment 268 [details]
Yet a newer diff
Comment 10 jskov 2000-11-07 07:27:59 UTC
Please kill this bug. If you need one that lives on forever, fine, but please
create a new one. I get tired of the mails.

Ta,
Jesper
Comment 11 support 2000-11-09 04:42:59 UTC
To: jglick@netbeans.org
Cc: dev@www.netbeans.org, keri@collab.net, chris@collab.net,
    bphipps@collab.net
Mime-Version: 1.0 (generated by tm-edit 7.108)
Date: Wed, 08 Nov 2000 20:39:11 -0800
Message-ID: <17286.973744751@collab.net>
From: "Niels P. Mayer" <npm@collab.net>
Subject: [dev] updated CVSROOT/{modules,cvsignore,cvswrappers}, found and fixed
problem

Regarding http://www.netbeans.org/bugs-cgi/show_bug.cgi?id=7435 ...

After updating CVSROOT/{modules,cvsignore,cvswrappers} as per
http://www.netbeans.org/bugs-cgi/showattachment.cgi?attach_id=268 I did a
test checkout of 'nbsrc' after updating modules and noted that the checkout
exited abnormally with the following error:

cvs [server aborted]: there is no repository
/cvs/workspaceswitcher/src/org/netbeans/modules/workspaceSwitcher

The following lines in the 'modules' patch were incongruous with the
repository, as directory 'workspaceswitcher/src' didn't exist:
! src_workspaceswitcher -a src_workspaceswitcher_1 src_workspaceswitcher_2
! src_workspaceswitcher_1 -d nbsrc/org/netbeans/modules/workspaceSwitcher
workspaceswitcher/src/org/netbeans/modules/workspaceSwitcher
! src_workspaceswitcher_2 -d nbsrc/org/netbeans/uiUtil
workspaceswitcher/src/org/netbeans/uiUtil

To resolve the error, I changed all '/src/org/' to '/org/' checked in my
changes, and tested again. This time 'nbsrc' was able to checkout
correctly.

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>> Niels Mayer (npm@collab.net)       http://www.cybertribe.com/mayer  <<
>>                    CollabNet, San Francisco, CA                     <<
>>  Collab.Net is hiring!  Go to http://www.collab.net/jobs for info.  <<
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Comment 12 Marian Mirilovic 2009-11-08 02:26:46 UTC
We recently moved out from Collabnet's infrastructure


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo