Bug 74014 - Cannot use vital symbols ('@', '{', ...) from international keyboard
Cannot use vital symbols ('@', '{', ...) from international keyboard
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Key bindings
5.x
Sun Solaris
: P2 with 1 vote (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: I18N
: 131391 157461 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 09:07 UTC by alexismp
Modified: 2009-01-27 11:19 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexismp 2006-03-27 09:07:14 UTC
Solaris 10 x86 update 1 (Generic_118844-26 i86pc i386 i86pc)
French Locale (fr_FR)
NetBeans 5.0
JDK 1.5.0_06

In the text editor, on a French keyboard (seems like others are also
experiencing this: German, Norwegian, ...), the user cannot access the '@' or
'{' symbols which require the use of the special 'Alt Gr' key. This modifier key
is being ignored (character appearing is as if no modifier key was pressed).

-> Using 1.5.0_06, this also fails using the simple Notepad swing sample (part
of the JDK).
-> Using 1.6.0 build 77, this is fixed for the Notepad sample, but still fails
using NetBeans 5.0 running this same 1.6b77 jdk version.

Note this has some similarities with BugId 40467.
Comment 1 alexismp 2006-03-27 11:56:58 UTC
NetBeans 4.1, Creator 2, Notepad all work fine with JDK 1.5.0_06 or latest Java
6 JDK with properly configured Xorg. Keyboard part of 'xorg.conf' (added all
'Option' lines):

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "CoreKeyboard"
        Option      "XkbRules"  "xorg"
        Option      "XkbModel"  "pc102"
        Option      "XkbLayout" "fr"
EndSection


NetBeans 5.0 (and 5.5) also work fine with JDK 1.5.0_06.
But still not luck with NetBeans 5.0+ running on latest mustang JDK (build 77)

Seems like the netbeans workaround used for Java 5 is no longer valid for Java 6.

Leaving status as NEW.
Comment 2 alexismp 2006-03-27 12:10:35 UTC
netbeans 4.1 works fine with both 1.5 and java 6 build 77...
Comment 3 _ tboudreau 2006-03-27 20:28:53 UTC
A good chance this was broken when multi-key keybinding support was added for 
5.0, perhaps.

Also check org/netbeans/core/windows/ShortcutKeyAndMenuEventProcessor - it has 
some platform specific hacks for, e.g. some versions of linux passing Alt as 
Meta...could be affecting it.
Comment 4 Jan Chalupa 2006-11-30 08:40:35 UTC
needs evaluation
Comment 5 Miloslav Metelka 2006-11-30 16:27:30 UTC
I've checked the DefaultEditorKit.DefaultKeyTypedAction and it seems that there
are no changes against the previous version but there may be changes in the key
events between the JDK versions (modifiers etc.; it happened several times in
the past already).

I've found two issues in JDK bug database that might be related:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4115509
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4835748

Also could you please download and run KeyEventDebug.jar from
http://editor.netbeans.org/servlets/ProjectDocumentList and simulate the problem
and grab the output and attach it to this issue? Thanks.
Comment 6 Jiri Prox 2006-11-30 17:42:43 UTC
I've tested this on Solaris and for 1.6.0 b104 the special character works for
both: notepad example and whole IDE (5.0 fcs)

For the 1.5.0_10 the behaviour is as described in first post.
Comment 7 Jan Chalupa 2006-11-30 17:56:01 UTC
Jiri, can you also try the workaround with xorg.conf for JDK 1.5.0_10?
Comment 8 olegsukhodolsky 2006-12-05 08:15:48 UTC
the problem looks similar to AWT bug #6253172
(http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6253172)

If it is not reproducible with the following XKB options it is most likely the
same problem:

   Option      "XkbLayout" "us,fr"
вместо  их чистого французского  
   Option      "XkbLayout" "fr"
и добавить что-нибудь вроде   
   Option      "XkbOptions" "grp:caps_toggle,grp_led:caps"
Comment 9 Jiri Prox 2006-12-05 10:41:44 UTC
Cannot make it work with any xconf.org configuration listed in this issue. 
(JDK 1.5.0_10, NB 5.0 fcs)

Workaround is to switch from Xorg to Xsun, it works fine there 
(JDK 1.5.0_10, NB 5.0fcs, NB 5.5 Fcs, german layout)
Comment 10 Jiri Prox 2006-12-05 14:26:29 UTC
Switching between Xsun and Xorg is quite simply if everithing is installed and
configured well. It is enough to run kdmconfig as super user and follow the
instructions on the screen. It is also possible to do basic configuration for
Xsun there, as setting keyboard layout. 
Comment 11 olegsukhodolsky 2006-12-05 19:07:15 UTC
Just realized that comment about AWT bug has some Russian text :(copy-paste :)

So, here is a translated version:

the problem looks similar to AWT bug #6253172
(http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6253172)

If it is not reproducible with the following XKB options it is most likely the
same problem:

try to use
   Option      "XkbLayout" "us,fr"
instead of pure French layout you have (Option      "XkbLayout" "fr" )

and you will also need to add something like this to switch layouts:
   Option      "XkbOptions" "grp:caps_toggle,grp_led:caps"
Comment 12 Marian Mirilovic 2007-07-15 22:44:53 UTC
From the comments above I see this was not working on :
- 1.5.0_06
- 1.6.0 build 77
Jiri approved that it works fine in 1.6.0 b104, but it still doesn't work 1.5.0_10 until user switches from Xorg to Xsun.
There is also reported JDK issue: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6253172

Am I right ? If so, I don't think we can do anything on our side, could we ?
Comment 13 Vitezslav Stejskal 2007-07-25 12:14:33 UTC
No, it does not seem to be Netbeans problem. Thanks
Comment 14 Vitezslav Stejskal 2008-03-28 14:13:57 UTC
*** Issue 131391 has been marked as a duplicate of this issue. ***
Comment 15 Jiri Prox 2009-01-27 11:19:15 UTC
*** Issue 157461 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo