Bug 73712 - Data Source Management API
Data Source Management API
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Libor Kotouc
issues@serverplugins
: API_REVIEW_FAST
: 72816 (view as bug list)
Depends on:
Blocks: 73678 74150 74197
  Show dependency treegraph
 
Reported: 2006-03-17 16:25 UTC by Libor Kotouc
Modified: 2006-03-29 13:32 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Javadoc, arch.xml, apichanges.xml, etc. (381.32 KB, application/octet-stream)
2006-03-17 16:28 UTC, Libor Kotouc
Details
j2eeserver diff (33.80 KB, patch)
2006-03-17 16:29 UTC, Libor Kotouc
Details | Diff
Javadoc (updated) (382.32 KB, application/octet-stream)
2006-03-27 14:42 UTC, Libor Kotouc
Details
proposed change (updated) (35.74 KB, patch)
2006-03-27 14:43 UTC, Libor Kotouc
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Libor Kotouc 2006-03-17 16:25:46 UTC
DS management API allows clients to access and manipulate the data sources. 
Data sources are created in the module and deployed when the module deployment
begins.
Data sources are accessed at two places - at the modules where they are stored
after creation and on the module's target server.
Comment 1 Libor Kotouc 2006-03-17 16:28:18 UTC
Created attachment 29290 [details]
Javadoc, arch.xml, apichanges.xml, etc.
Comment 2 Libor Kotouc 2006-03-17 16:29:10 UTC
Created attachment 29291 [details]
j2eeserver diff
Comment 3 Libor Kotouc 2006-03-17 17:04:26 UTC
More about the API change motivation.

1. There are components like Persistence Unit wizard or Entity classes from
Database wizard which need to allow user to choose a data source or create a new
one when the requested data source does not exist yet.
For this we need to show the list of data sources available on the server and
other data sources which may be already created in the IDE but not deployed yet.
Other request is to provide functionality for creating a new data source and
registering it on the server.
Data source registering is then done without user interaction during project
deployment.

2. Another reason for the proposed change is the number of servers supported by
the IDE. It make sense to provide some common way for data source management.

3. Current implementation of 'Enterprise resources' actions (like Use database,
Call EJB...) are now implemented in several plugins with use of listeners
registered for the changes made in the standard descriptors. The action modifies
a standard descriptor and listener then writes appropriate changes into 
server-specific deployment descriptor(s), generates the resources and so on.
API proposed allows the action to invoke creation of a server-specific part
directly and makes so this functionality consistent with the rest of steps taken
in the action. Also problem with the update events fired from the multiview
editor is solved (manual editing of a standard deployment descriptor now leads
to the events fired and thus to generation of new unintentional data sources).
Comment 4 Libor Kotouc 2006-03-17 17:05:37 UTC
*** Issue 72816 has been marked as a duplicate of this issue. ***
Comment 5 Libor Kotouc 2006-03-27 14:42:53 UTC
Created attachment 29426 [details]
Javadoc (updated)
Comment 6 Libor Kotouc 2006-03-27 14:43:51 UTC
Created attachment 29427 [details]
proposed change (updated)
Comment 7 Libor Kotouc 2006-03-27 14:46:13 UTC
I added sherold's suggestions - mostly Javadoc improvements and API generification.
Comment 8 Libor Kotouc 2006-03-27 14:49:32 UTC
If there are no other comments, I will commit the changes into release55 branch
tomorrow.
Comment 9 Libor Kotouc 2006-03-29 13:32:14 UTC
The chnages were commited into the release55 branch.

Checking in src/org/netbeans/modules/j2ee/deployment/config/ConfigSupportImpl.java;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/config/ConfigSupportImpl.java,v
 <--  ConfigSupportImpl.java
new revision: 1.40.2.4.2.2; previous revision: 1.40.2.4.2.1
done
Checking in arch.xml;
/cvs/j2eeserver/arch.xml,v  <--  arch.xml
new revision: 1.11.10.3.2.2; previous revision: 1.11.10.3.2.1
done
Checking in apichanges.xml;
/cvs/j2eeserver/apichanges.xml,v  <--  apichanges.xml
new revision: 1.16.6.3.2.1; previous revision: 1.16.6.3
done
Checking in
src/org/netbeans/modules/j2ee/deployment/plugins/api/DatasourceManager.java;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/plugins/api/Attic/DatasourceManager.java,v
 <--  DatasourceManager.java
new revision: 1.1.6.1; previous revision: 1.1
done
Checking in
src/org/netbeans/modules/j2ee/deployment/plugins/api/ConfigurationSupport.java;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/plugins/api/ConfigurationSupport.java,v
 <--  ConfigurationSupport.java
new revision: 1.2.42.2.2.1; previous revision: 1.2.42.2
done
Checking in
src/org/netbeans/modules/j2ee/deployment/plugins/api/OptionalDeploymentManagerFactory.java;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/plugins/api/OptionalDeploymentManagerFactory.java,v
 <--  OptionalDeploymentManagerFactory.java
new revision: 1.4.34.1; previous revision: 1.4
done
Checking in nbproject/project.properties;
/cvs/j2eeserver/nbproject/project.properties,v  <--  project.properties
new revision: 1.9.34.2; previous revision: 1.9.34.1
done
Checking in
src/org/netbeans/modules/j2ee/deployment/devmodules/spi/J2eeModuleProvider.java;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/devmodules/spi/J2eeModuleProvider.java,v
 <--  J2eeModuleProvider.java
new revision: 1.47.30.3.2.1; previous revision: 1.47.30.3
done
Checking in src/org/netbeans/modules/j2ee/deployment/devmodules/spi/.cvsignore;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/devmodules/spi/Attic/.cvsignore,v
 <--  .cvsignore
new revision: 1.1.6.1; previous revision: 1.1
done
Checking in
src/org/netbeans/modules/j2ee/deployment/common/api/DatasourceAlreadyExistsException.java;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/common/api/Attic/DatasourceAlreadyExistsException.java,v
 <--  DatasourceAlreadyExistsException.java
new revision: 1.1.4.1; previous revision: 1.1
done
Checking in src/org/netbeans/modules/j2ee/deployment/common/api/Datasource.java;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/common/api/Attic/Datasource.java,v
 <--  Datasource.java
new revision: 1.1.4.1; previous revision: 1.1
done
Checking in src/org/netbeans/modules/j2ee/deployment/devmodules/api/Deployment.java;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/devmodules/api/Deployment.java,v
 <--  Deployment.java
new revision: 1.21.6.1.2.1; previous revision: 1.21.6.1
done
Checking in src/org/netbeans/modules/j2ee/deployment/impl/ServerInstance.java;
/cvs/j2eeserver/src/org/netbeans/modules/j2ee/deployment/impl/ServerInstance.java,v
 <--  ServerInstance.java
new revision: 1.61.2.4.2.1; previous revision: 1.61.2.4
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo