Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 73415 - Can't deploy J2EE application in Glassfish
Can't deploy J2EE application in Glassfish
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 9
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Vince Kraemer
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-09 10:27 UTC by Petr Blaha
Modified: 2006-05-31 19:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
patch (4.75 KB, patch)
2006-03-09 12:55 UTC, Petr Blaha
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Blaha 2006-03-09 10:27:45 UTC
[build 20060309]
Steps;
1) create J2EE application with web and ejb module
2) deploy it in App server
ERROR: Deploying application in domain failed; Error loading deployment
descriptors for module [Znova] -- www.sun.com
/home.local/blaha/ide/q-build/netbeans/projects/Znova/nbproject/build-impl.xml:219:
Deployment error:
The module has not been deployed.
See the server log for details.
BUILD FAILED (total time: 3 seconds)

This feature is working in yesterday's build.

Server error:
ADM1064:The upload file at [/tmp/s1astempdomain1server184447312/Znova.ear]
exists and will be overwritten.
ADM1006:Uploading the file to:[/tmp/s1astempdomain1server184447312/Znova.ear]
"DPL8005: Deployment Descriptor parsing failure : www.sun.com"
Exception occured in J2EEC Phase
com.sun.enterprise.deployment.backend.IASDeploymentException: Error loading
deployment descriptors for module [Znova] -- www.sun.com
        at
com.sun.enterprise.deployment.backend.Deployer.loadDescriptors(Deployer.java:362)
        at
com.sun.enterprise.deployment.backend.AppDeployerBase.loadDescriptors(AppDeployerBase.java:315)
        at
com.sun.enterprise.deployment.backend.AppDeployer.explodeArchive(AppDeployer.java:321)
        at
com.sun.enterprise.deployment.backend.AppDeployer.deploy(AppDeployer.java:178)
        at
com.sun.enterprise.deployment.backend.AppDeployer.doRequestFinish(AppDeployer.java:125)
        at
com.sun.enterprise.deployment.phasing.J2EECPhase.runPhase(J2EECPhase.java:169)
        at
com.sun.enterprise.deployment.phasing.DeploymentPhase.executePhase(DeploymentPhase.java:95)
        at
com.sun.enterprise.deployment.phasing.PEDeploymentService.executePhases(PEDeploymentService.java:848)
        at
com.sun.enterprise.deployment.phasing.PEDeploymentService.deploy(PEDeploymentService.java:260)
        at
com.sun.enterprise.deployment.phasing.PEDeploymentService.deploy(PEDeploymentService.java:716)
        at
com.sun.enterprise.management.deploy.DeployThread.deploy(DeployThread.java:165)
        at
com.sun.enterprise.management.deploy.DeployThread.run(DeployThread.java:194)
Caused by: java.net.UnknownHostException: www.sun.com
        at
com.sun.enterprise.server.ss.provider.ASClientSocketImpl.connect(ASClientSocketImpl.java:190)
        at java.net.Socket.connect(Socket.java:516)
        at java.net.Socket.connect(Socket.java:466)
        at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
        at sun.net.www.http.HttpClient.openServer(HttpClient.java:369)
        at sun.net.www.http.HttpClient.openServer(HttpClient.java:481)
        at sun.net.www.http.HttpClient.<init>(HttpClient.java:214)
        at sun.net.www.http.HttpClient.New(HttpClient.java:287)
        at sun.net.www.http.HttpClient.New(HttpClient.java:299)
        at
sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:785)
        at
sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:726)
        at
sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:651)
        at
sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:951)
        at
com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(XMLEntityManager.java:677)
        at
com.sun.org.apache.xerces.internal.impl.XMLEntityManager.startEntity(XMLEntityManager.java:1316)
        at
com.sun.org.apache.xerces.internal.impl.XMLEntityManager.startDTDEntity(XMLEntityManager.java:1283)
        at
com.sun.org.apache.xerces.internal.impl.XMLDTDScannerImpl.setInputSource(XMLDTDScannerImpl.java:283)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$DTDDriver.dispatch(XMLDocumentScannerImpl.java:1160)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$DTDDriver.next(XMLDocumentScannerImpl.java:1066)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(XMLDocumentScannerImpl.java:986)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:645)
        at
com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:137)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:508)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
        at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
        at
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
        at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
        at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
        at javax.xml.parsers.SAXParser.parse(SAXParser.java:395)
        at
com.sun.enterprise.deployment.io.DeploymentDescriptorFile.read(DeploymentDescriptorFile.java:279)
        at
com.sun.enterprise.deployment.archivist.Archivist.readRuntimeDeploymentDescriptor(Archivist.java:511)
        at
com.sun.enterprise.deployment.archivist.ApplicationArchivist.readRuntimeDeploymentDescriptor(ApplicationArchivist.java:388)
        at
com.sun.enterprise.deployment.backend.Deployer.loadDescriptors(Deployer.java:320)
        ... 11 more
Comment 1 Lukas Jungmann 2006-03-09 10:38:34 UTC
Incorrect component. AS plugin issue?
Comment 2 Lukas Jungmann 2006-03-09 11:05:52 UTC
Setting http.proxy* options on appserver side leads to:

com.sun.enterprise.deployment.backend.IASDeploymentException: Error loading
deployment descriptors for module [EnterpriseApplication1] --
http://www.sun.com/software/dtd/appserver/sun-application_5_0-0.dtd
        at
com.sun.enterprise.deployment.backend.Deployer.loadDescriptors(Deployer.java:362)
        at
com.sun.enterprise.deployment.backend.AppDeployerBase.loadDescriptors(AppDeployerBase.java:318)
...
Caused by: java.io.FileNotFoundException:
http://www.sun.com/software/dtd/appserver/sun-application_5_0-0.dtd
...

in AS log
Comment 3 Petr Blaha 2006-03-09 12:53:06 UTC
The problem is that sun-application.xml has incorrect PUBLIC ID. Suggested patch
is attached.
Comment 4 Petr Blaha 2006-03-09 12:55:46 UTC
Created attachment 29185 [details]
patch
Comment 5 Vince Kraemer 2006-03-09 14:43:29 UTC
thanks.  I will fix this today
Comment 6 _ ludo 2006-03-09 18:56:19 UTC
patch applied
Comment 7 Petr Blaha 2006-03-10 09:37:26 UTC
[build 20060310]


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo