Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 73400 - Add option "jar libs into project jar" or another solution
Add option "jar libs into project jar" or another solution
Status: RESOLVED DUPLICATE of bug 70077
Product: java
Classification: Unclassified
Component: Project
5.x
All All
: P3 (vote)
: TBD
Assigned To: Tomas Zezula
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 21:51 UTC by rogier
Modified: 2006-03-13 10:41 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rogier 2006-03-08 21:51:18 UTC
I have a couple of projects that each reference to a "common" project. This 
common project itself has a number of external jars it uses that are placed in 
the lib dir of this project. These jars are only needed for the common 
classfiles, not the other projects.

When I reference the project from my main project, only the jar with the 
common classfiles is created, not including the classfiles of the external 
jars. 

My solution so far is to redefine the pre-jar target of the common project, in 
which I unjar the external libs in the build dir, which means they will be 
incorporated into the common jar. The drawback of this is when I have selected 
the option "build projects on classpath" in my main project, it will unjar the 
external libs of the common project, each time I build the project. This makes 
me select/unselect the option when I'm working/not working on the common 
project, which is a bit cumbersome.

It would be great if there would be an option to include the classfiles of the 
external jars in a project jar, which can then be referenced by other projects 
as a single working entity, without further hassle of dealing with the 
dependencies of the "common" project. 

A solution would be to add an option "include classfiles of libraries in jar" 
in the libraries tab.

At the same time, this would remove the need for people who want to 
redistribute a project with external jars as a single jar, to include the 
unjar in the pre-jar in the build.xml. 

Please help me if I'm missing some option that can resolve this issue in other 
ways.

Thanks.
Comment 1 Jesse Glick 2006-03-08 21:53:02 UTC
Probably duplicate of something filed; also a FAQ entry in the wiki somewhere, I
think.
Comment 2 Tomas Zezula 2006-03-13 10:41:46 UTC
Yes, it is a duplicate of #70077

*** This issue has been marked as a duplicate of 70077 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo