Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 73286 - byte[] elements are not recognised in WSDL
byte[] elements are not recognised in WSDL
Status: CLOSED WONTFIX
Product: javame
Classification: Unclassified
Component: Web Services
5.x
PC Windows XP
: P1 (vote)
: 5.x
Assigned To: Michal Skvor
issues@mobility
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-06 14:43 UTC by ntsarb
Modified: 2008-09-10 15:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ntsarb 2006-03-06 14:43:35 UTC
It appears that the stub generator cannot properly generate methods returning an
object of type: byte[]. Same is true for char[] (if char is supported by WS-I BP
1.0).

When the stub is generated, a parametre "UNKNOWN" is found in the method definition.
Comment 1 Lukas Hasik 2006-03-09 15:41:22 UTC
the byte[] is problem. Reassigning. It needs investigation if it's MP problem of
WTK.

char[] isn't allowed by
http://www.w3.org/TR/xmlschema-2/#built-in-primitive-datatypes
Comment 2 Michal Skvor 2006-03-16 10:54:48 UTC
The problem is in WTK Stub generator. 

Bug is turned over to WTK team for fix (bugparade #6397524). 
Comment 3 Lukas Hasik 2006-06-23 14:28:52 UTC
moving to mobility component
Comment 4 Lukas Hasik 2006-06-26 11:19:41 UTC
does it mean that it cannot be fixed on Mobility side? If yes then we should
close  this issue, don't we? 

Or is there any reason to keep this issue opened? It's P1...
Comment 5 Michal Skvor 2006-07-27 14:52:49 UTC
Fix is on the WTK team.
Comment 6 Lukas Hasik 2006-09-19 11:16:25 UTC
v
Comment 7 Lukas Hasik 2007-03-19 11:46:00 UTC
this bug was reported to WTK as bug #6397524 
Comment 8 Ivan Sidorkin 2008-09-10 15:57:21 UTC
close old issues


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo