Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 73144 - JSTL - all items
JSTL - all items
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Palette
5.x
All All
: P3 (vote)
: 6.x
Assigned To: pslechta
issues@javaee
61fixes1-fixed
:
: 67457 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 16:26 UTC by Petr Pisl
Modified: 2008-06-04 08:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2006-03-01 16:26:14 UTC
1) The items should check, whether is there defined the jstl core library, if
not then add the <%@taglib %> directive with the definition
2)When there is already jstl core defined on the page, then the items should
find out the appropriate prefix. The prefix doesn't have to be "c".
Comment 1 Libor Kotouc 2006-06-15 10:21:05 UTC
fixable in 5.5
Comment 2 David Konecny 2007-10-23 13:44:29 UTC
*** Issue 67457 has been marked as a duplicate of this issue. ***
Comment 3 Jiri Prox 2008-04-11 01:13:13 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 4 pslechta 2008-04-14 10:42:06 UTC
Reproduced on 6.1 dev build.
Comment 5 pslechta 2008-04-15 10:43:50 UTC
Fixed.

http://hg.netbeans.org/main/rev/2a8313a5ef53
Comment 6 Dan Kolar 2008-04-23 15:24:12 UTC
Reopened, 2) doesn't work, is library has other prefix than "c", ide inserts another import with "c" prefix.
Comment 7 pslechta 2008-04-23 15:55:53 UTC
This may happen only if JSP parser has problem to parse the page.
Please provide example JSP file and steps how to reproduce it.
Thanks.
Comment 8 pslechta 2008-04-23 19:11:31 UTC
There may be racing condition in one corner case: when user adds code from palette, then renames prefix of newly
inserted taglib, and then inserts another code from palette. Old taglib prefix may be used for newly inserted code in
this case. This is caused by JSP parser (the speed of parser and caching). This scenario is corner case, most developers
won't change taglib prefix directly after insertion. This behavior is confirmed by QA (dkolar). New issue may be created
for this corner case.
Comment 9 Petr Blaha 2008-04-24 14:32:37 UTC
v
Comment 10 pslechta 2008-04-28 11:33:59 UTC
The fix has been ported into the release61_fixes branch.

http://hg.netbeans.org/release61_fixes/rev/2833dc3ab265


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo