Bug 72556 - need for facelet support
need for facelet support
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: JSF
5.x
All All
: P2 with 21 votes (vote)
: 6.x
Assigned To: _ potingwu
issues@javaee
: PLAN
: 89857 122887 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-11 00:04 UTC by _ ludo
Modified: 2008-09-23 21:35 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Editing of xhtml file from Seam examples - screenshot (71.78 KB, image/png)
2006-06-06 17:52 UTC, Petr Jiricka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ ludo 2006-02-11 00:04:43 UTC
We now need to add support for facelets:
https://facelets.dev.java.net/
and mdofiy the faces config and web.xml with:

<faces-config>
  <application>
    <!-- tell JSF to use Facelets -->
    <view-handler>com.sun.facelets.FaceletViewHandler</view-handler>
  </application>
</faces-config>

JavaServer Faces defaults to JSP files for defining views (*.jsp). You will want
to change this to some other type in your WEB-INF/web.xml.

<context-param>
  <param-name>javax.faces.DEFAULT_SUFFIX</param-name>
  <param-value>.xhtml</param-value>
</context-param>


This will help working on samples using the Seam framework that use facelets.
Comment 1 Petr Jiricka 2006-06-06 17:51:33 UTC
Now I also see that we don't even color some facelets file like (X)HTML. See the
attached screenshot.
Comment 2 Petr Jiricka 2006-06-06 17:52:51 UTC
Created attachment 30831 [details]
Editing of xhtml file from Seam examples - screenshot
Comment 3 _ ludo 2006-06-06 19:19:42 UTC
So does that mean that
http://www.netbeans.org/issues/show_bug.cgi?id=72558
is not fixed ?

Comment 4 Petr Pisl 2006-06-06 23:05:08 UTC
The attached screenshot displays a file with composition DOCTYPE. The file is
according  xhtml1-trasitional.dtd and of course the file is not recognize by any
dataloader . When you create html file with the new template (#72558) the file
has html DOCTYPE and  is according xhtml1-strict.dtd -> xml dataloader care
about this file.

Fixing this should be easy.
Comment 5 Petr Pisl 2007-05-21 09:07:55 UTC
The Facelets support for NetBeans is available on
https://nbfaceletssupport.dev.java.net/. There are available previews, not final
bits yet.
Comment 6 _ potingwu 2008-04-23 18:12:51 UTC
*** Issue 89857 has been marked as a duplicate of this issue. ***
Comment 7 Jayashri Visvanathan 2008-04-25 19:05:21 UTC
For 6.5, the plan is to deliver Facelets support via beta update center.
Comment 8 rdelaplante 2008-04-25 19:45:17 UTC
Is 6.5 FCS going to be November/December 2008?  Facelets support will only be beta by then?  
This will not be integrated into Visual Web designer, right?

Comment 9 Jayashri Visvanathan 2008-04-25 20:16:14 UTC
 Facelets is going to be standardized in JSF 2.0, thats one of the reasons why I feel we should leave Facelets on beta
update center. No plans yet to integrate this into Visual web designer. May be this should also wait until JSF 2.0

thanks
Comment 10 _ potingwu 2008-05-16 23:32:09 UTC
I have blog the simple steps of how to build the NBMs for NetBeans 6.1. You may even just download the binaries there if
you do want to skip the DIY.

   http://blogs.sun.com/poting/entry/build_and_install_facelets_support

To summary the build steps:
   1. get the source
       cvs -d :pserver:your_userid@cvs.dev.java.net:/cvs login
       cvs -d :pserver:your_userid@cvs.dev.java.net:/cvs checkout nbfaceletssupport
   2. open the projects from NetBeans 6.1
   3. right click on the 'Facelets Suite' node and select Create NBMs

That's it! You don't even need to setup the projects, ... 

This is still not final and official yet; waiting for QA testing. If you found any serious issue, please report here!
Comment 11 Petr Jiricka 2008-06-02 17:52:29 UTC
*** Issue 122887 has been marked as a duplicate of this issue. ***
Comment 13 Petr Pisl 2008-06-13 09:05:38 UTC
Thank to Po-Ting to the great job.
Comment 14 tkellerer 2008-09-23 21:27:55 UTC
Where do I report issues against the Facelet integration with NB 6.5?

It does not work properly with a Maven based project
Comment 15 _ potingwu 2008-09-23 21:35:26 UTC
Please file nb-facelets issues by 'Issue tracker' under https://nbfaceletssupport.dev.java.net.

BTW, Facelets on Maven project is currently not supported. I mean, not tested.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo