Bug 72352 - Exception editing xml
Exception editing xml
Status: VERIFIED DUPLICATE of bug 70678
Product: xml
Classification: Unclassified
Component: Text-Edit
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Marek Fukala
issues@xml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 16:21 UTC by brviking
Modified: 2007-09-25 01:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brviking 2006-02-07 16:21:25 UTC
While editing XML, I got following exception:

java.lang.IndexOutOfBoundsException: Index: 2, Size: 0
	at java.util.ArrayList.add(ArrayList.java:369)
	at
org.netbeans.modules.xml.text.navigator.TreeNodeAdapter.elementAdded(TreeNodeAdapter.java:305)
	at
org.netbeans.modules.editor.structure.api.DocumentElement.fireDocumentElementEvent(DocumentElement.java:300)
	at
org.netbeans.modules.editor.structure.api.DocumentElement.childAdded(DocumentElement.java:311)
	at
org.netbeans.modules.editor.structure.api.DocumentModel$DocumentModelModificationTransaction.removeDE(DocumentModel.java:1042)
	at
org.netbeans.modules.editor.structure.api.DocumentModel$DocumentModelModificationTransaction.commit(DocumentModel.java:894)
	at
org.netbeans.modules.editor.structure.api.DocumentModel$DocumentModelModificationTransaction.access$100(DocumentModel.java:782)
	at
org.netbeans.modules.editor.structure.api.DocumentModel.updateModel(DocumentModel.java:440)
	at
org.netbeans.modules.editor.structure.api.DocumentModel.access$400(DocumentModel.java:97)
	at
org.netbeans.modules.editor.structure.api.DocumentModel$2.run(DocumentModel.java:414)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:493)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:926)
Comment 1 brviking 2006-03-06 13:07:11 UTC
Changing priority for crashes as suggested by Roman Strobl in NB users list.
Comment 2 Marek Fukala 2006-03-06 13:21:40 UTC
I suppose you do not have any exact steps to reproduce, right?

*** This issue has been marked as a duplicate of 70678 ***
Comment 3 Jiri Kovalsky 2006-03-06 13:59:32 UTC
Verified as duplicate of another issue. If you happen to reproduce the problem
again, don't hesitate to let us know what you did before. Thanks a lot !


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo