Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 72267 - Linux installer requires bc and fails to report so in a friendly manner
Linux installer requires bc and fails to report so in a friendly manner
Status: VERIFIED DUPLICATE of bug 65482
Product: installer
Classification: Unclassified
Component: Code
5.x
All Linux
: P3 (vote)
: 6.x
Assigned To: mslama
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-05 14:30 UTC by _ hair
Modified: 2007-09-29 13:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ hair 2006-02-05 14:30:43 UTC
The netbeans-profiler-5_0-linux.bin dumps (over and over again)

 line 189: bc: command not found
 line 404: [: : integer expression expected

Pretty obvious to a competent linux user, but linux is being adopted by many not
so competent users at an increasing rate.

All requirements for the install script should be checked and reported in a
friendly way.
Comment 1 mslama 2006-02-20 09:58:56 UTC
Iterate PATH if bc is present. If not print nicer error message to console.
Comment 2 mslama 2007-07-26 10:50:45 UTC
Fixed for NB 6.0: New installer engine does not depend on 'bc'.

*** This issue has been marked as a duplicate of 65482 ***
Comment 3 _ hair 2007-09-29 13:18:14 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo