Bug 72173 - assert in BasicBrandingModel.initBundleKeys
assert in BasicBrandingModel.initBundleKeys
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Jesse Glick
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-02 15:20 UTC by pzajac
Modified: 2006-02-13 13:49 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
assert.txt (2.98 KB, text/plain)
2006-02-02 15:29 UTC, pzajac
Details
This diff contains additional assert that isn't satisfied when the problem occures (1.55 KB, patch)
2006-02-06 10:56 UTC, rmatous
Details | Diff
Suggested fix (1.25 KB, text/html)
2006-02-06 16:00 UTC, rmatous
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2006-02-02 15:20:34 UTC
200601312300
Assert error was thrown after clicking to module suite properties.
Comment 1 pzajac 2006-02-02 15:29:47 UTC
Created attachment 28718 [details]
assert.txt
Comment 2 Tomas Danek 2006-02-02 15:52:47 UTC
I've seen it too, but for me reproducible only randomly. 
Comment 3 pzajac 2006-02-03 09:36:39 UTC
I am able reproduce it every time.
Comment 4 Jesse Glick 2006-02-03 13:04:52 UTC
Thrown (acc. to pzajac, though not reported here) when selecting 5.5 platform.
Seems that org/netbeans/core/startup/Bundle.properties#currentVersion is
undefined. Why?? This key in core/startup is fine. And
ide/branding/core/startup/src/org/netbeans/core/startup/Bundle_nb.properties on
release55 has as expected:

currentVersion=NetBeans 5.5 Preview (Build {0})

In any event, apisupport should not throw assertions just because some bundle
key is missing. But root cause needs to be investigated.
Comment 5 pzajac 2006-02-03 14:29:04 UTC
Yes, I can reproduce it when is selected nb55 platform.
Comment 6 rmatous 2006-02-03 14:58:45 UTC
suiteProperties.getActivePlatform().getModules() returns array of
ModuleEntry-ies but platform6/core/core.jar is sometimes not present in nb55.
Comment 7 Jesse Glick 2006-02-03 15:39:29 UTC
"platform6/core/core.jar is sometimes not present in nb55" - ???
Comment 8 rmatous 2006-02-03 16:55:52 UTC
I'm somehow confused with this issue. I expect this issue is right reported
against 5.0u1 and the problem occures when you use 5.0u1 build for developing
suite against nb5.5. Im I right ? In any case I'm not able to reproduce neither
in 5.0u1 build nor in 5.5 (in both cases I developed against 5.5). 

Maybe I'm doing something wrong. Anyway I tested it on Linux not on Windows. 
I can naturally strip those asserts but I would rather find the cause. 

Please, forget my comment about missing platform6/core/core.jar in nb55 (just my
mistake).

  
Comment 9 Jesse Glick 2006-02-03 18:33:04 UTC
The actual apisupport code throwing the assertion is that of 5.0.

Awaiting further details to reproduce the problem.
Comment 10 pzajac 2006-02-06 09:57:51 UTC
How to reproduce:
1) Install the netbeans-5_5-preview with appserver distribution
2) Create a module suite 
3) Show propperties of module suite
4) The exception was thrown 
I was talking about that with Radek. He told me he is able to reproduce it.  
Comment 11 rmatous 2006-02-06 10:45:16 UTC
Evaluation:
There are two modules containing the same localized name ("Startup"):
/platform6/core/core.jar 
/infra2/modules/com-sun-tools-ide-startup.jar

For their ModuleEntry-ies is true that compareTo (implemented in AbstractEntry)
returns 0 and then method NbPlatform.getModules() doesn't return ModuleEntry for
org.netbeans.core.startup. 
Comment 12 rmatous 2006-02-06 10:56:18 UTC
Created attachment 28765 [details]
This diff contains additional assert that isn't satisfied when the problem occures
Comment 13 rmatous 2006-02-06 16:00:08 UTC
Created attachment 28771 [details]
Suggested fix
Comment 14 Jesse Glick 2006-02-06 17:36:51 UTC
Fix looks correct to me. I thought I had caught all such unsafe comparators a
few months ago, but apparently not. Should IMHO go into trunk, javaee5, and
apisupport_50u1.
Comment 15 Jesse Glick 2006-02-06 20:43:44 UTC
release55 merge, please verify:

Checking in
project/src/org/netbeans/modules/apisupport/project/universe/AbstractEntry.java;
/shared/data/ccvs/repository/apisupport/project/src/org/netbeans/modules/apisupport/project/universe/AbstractEntry.java,v
 <--  AbstractEntry.java
new revision: 1.3.8.1.2.1; previous revision: 1.3.8.1
done
Comment 16 Jesse Glick 2006-02-06 20:52:12 UTC
Merged to apisupport_50u1, trunk merge coming soon...

Checking in AbstractEntry.java;
/shared/data/ccvs/repository/apisupport/project/src/org/netbeans/modules/apisupport/project/universe/AbstractEntry.java,v
 <--  AbstractEntry.java
new revision: 1.7.2.1; previous revision: 1.7
done
Comment 17 Jesse Glick 2006-02-06 22:10:47 UTC
Trunk:

committed     Up-To-Date  1.8        
apisupport/project/src/org/netbeans/modules/apisupport/project/universe/AbstractEntry.java
Comment 18 Jesse Glick 2006-02-07 15:03:34 UTC
And javaee5:

Checking in AbstractEntry.java;
/shared/data/ccvs/repository/apisupport/project/src/org/netbeans/modules/apisupport/project/universe/AbstractEntry.java,v
 <--  AbstractEntry.java
new revision: 1.3.8.2; previous revision: 1.3.8.1
done
Comment 19 pzajac 2006-02-13 13:49:33 UTC
verified in nb55(last week)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo