Bug 72113 - Module Project Customizer - unify spaces between components
Module Project Customizer - unify spaces between components
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
5.x
All All
: P4 (vote)
: 7.3
Assigned To: Martin Kozeny
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 11:53 UTC by pzajac
Modified: 2012-12-12 08:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2006-02-01 11:53:00 UTC
[20060201]
The spaces between components are different in many panels of Project Cutomizer.

For Example :
Sources Panel - Libraries Panel
There are more free pixels between project Folder and Source level in Sources
panel than betwwen Java Platform and NetBeans platform in project in Libraries Panle

Add more free pixels between buttons in Libraries and API versioning panel.
Comment 1 Martin Krauskopf 2006-02-01 12:08:30 UTC
Presuambly true. Not sure about TBD yet.
Comment 2 Jesse Glick 2006-02-01 15:59:29 UTC
Most apisupport GUI panels are still using GridBagLayout and should at some
point be rebuilt using free design to use L&F-specific spacing and text
alignment, I guess.
Comment 3 Martin Krauskopf 2006-02-27 11:18:38 UTC
> Add more free pixels between buttons in Libraries and API versioning panel.

ui/customizer/CustomizerVersioning.form; 1.13 -> 1.14;
ui/customizer/CustomizerVersioning.java; 1.38 -> 1.39;
Comment 4 Martin Krauskopf 2006-02-27 13:46:06 UTC
The part was backported.

ui/customizer/CustomizerVersioning.form; 1.13 -> 1.13.8.1;
ui/customizer/CustomizerVersioning.java; 1.38 -> 1.38.2.1;
Comment 5 Martin Krauskopf 2008-02-07 17:50:18 UTC
I'm not working on APISupport anymore. Reassigning to owner of the component, so
the issue is not 'forgotten' forever.
Comment 6 rmichalsky 2008-11-24 15:08:46 UTC
Not into 7.0 or next release. Feel free to reopen if more important than it seems.
Comment 7 Quality Engineering 2009-11-02 10:56:57 UTC
NetBeans.org Migration: changing resolution from LATER to WONTFIX
Comment 8 Jesse Glick 2009-11-23 13:53:33 UTC
Still valid?
Comment 9 rmichalsky 2009-11-24 03:25:55 UTC
Fixed for edit boxes in Source and Libraries, buttons in Libraries and API Versioning are still ugly - not evenly spaced and e.g. Add and Remove buttons jump up and down when switching tabs. Cosmetic issue.
Comment 10 Martin Kozeny 2012-12-11 12:39:50 UTC
Add, Remove and other buttons are not moving now when switching between tabs.
Comment 11 Quality Engineering 2012-12-12 02:44:59 UTC
Integrated into 'main-golden', will be available in build *201212120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e6626619a10b
User: Martin Kozeny <mkozeny@netbeans.org>
Log: #72113: Add, Remove and other buttons are not moving now when switching between tabs


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo