Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 72060 - [50cat] Replace Constructor with Factory Method , make all constructor private and instead creat a factory method to return an instance
[50cat] Replace Constructor with Factory Method , make all constructor privat...
Status: RESOLVED DUPLICATE of bug 197190
Product: java
Classification: Unclassified
Component: Refactoring
5.x
All All
: P3 (vote)
: TBD
Assigned To: Jan Becicka
issues@java
:
: 174388 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 13:45 UTC by kalali
Modified: 2011-04-04 13:21 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kalali 2006-01-31 13:45:39 UTC
[ BUILD # : 20060110 ]
[ JDK VERSION : 1.6 ]

Replace Constructor with Factory Method , make all constructor private and instead creat a factory method to return an instance
Comment 1 Jan Pokorsky 2009-12-02 08:04:36 UTC
*** Bug 174388 has been marked as a duplicate of this bug. ***
Comment 2 Jan Becicka 2011-04-04 13:21:06 UTC

*** This bug has been marked as a duplicate of bug 197190 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo