Bug 71252 - Problem with Turkish regional settings (failure to start and install)
Problem with Turkish regional settings (failure to start and install)
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: Autoupdate
5.x
PC Windows XP
: P2 (vote)
: 5.x
Assigned To: Jiri Rechtacek
issues@platform
http://bugs.sun.com/bugdatabase/view_...
jdk_bug_6341798
: I18N, JDK_SPECIFIC
: 72428 73275 74169 86738 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 01:13 UTC by arifi
Modified: 2006-10-12 09:32 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshots and messages.log file (31.04 KB, application/x-compressed)
2006-01-11 01:16 UTC, arifi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description arifi 2006-01-11 01:13:32 UTC
The netbeans ide fails to install,start or uninstall when in Regional and 
Language Settings -> Regional Options -> Standards and formats is set to 
Turkish.

The log file messages.log contains:
java.beans.IntrospectionException: Method not found: isİdeIdentity

I assume that the third letter of the method not found should be 'I' (hence 
the method name 'isIdeIdentity'. However (I am not sure whether it displays 
properly on your screen now) it is 'İ'. This letter is the Turkish uppercase 
for 'i', and it is actually a dotted 'I'. This is a typical problem we 
encounter in many software packages. You can find a pretty good explanation at 
http://cafe.elharo.com/java/turkish/ .

Everything installs, starts and uninstalls fine if the setting is set to 
English, but this is not acceptable for 90% of Turkish users. 

I believe this problem is probably only a typo, but it should not make its way 
into the actual release.

Best regards
Arifi Koseoglu
Comment 1 arifi 2006-01-11 01:16:05 UTC
Created attachment 28343 [details]
Screenshots and messages.log file
Comment 2 Milan Kubec 2006-01-13 12:41:45 UTC
Already reported, bug in installshield software.

*** This issue has been marked as a duplicate of 52012 ***
Comment 3 arifi 2006-01-15 09:50:54 UTC
Hi,
The issue this one has been marked a duplicate of relates to installing only. 
However, the problem I reported happens when trying to start the ide after 
having installed the archive version. Installshield is not involved. Repeating 
some portion of my original explanation:

The log file messages.log contains:
java.beans.IntrospectionException: Method not found: isİdeIdentity

I assume that the third letter of the method not found should be 'I' (hence 
the method name 'isIdeIdentity'. However (I am not sure whether it displays 
properly on your screen now) it is 'İ'. This letter is the Turkish uppercase 
for 'i', and it is actually a dotted 'I'. This is a typical problem we 
encounter in many software packages. You can find a pretty good explanation at 
http://cafe.elharo.com/java/turkish/ .

Best regards,
Arifi Koseoglu
Comment 4 Milan Kubec 2006-01-17 12:56:57 UTC
Probably core issue then, please evaluate. Thanks.
Comment 5 Marian Mirilovic 2006-01-17 13:35:07 UTC
It looks like one of the module is broken or contains method which name concains
localized character ...

Jirka, 
it's P2, autoupdate is on the stack trace, probably you know exactly what is
broken, anyway I don't think it's on our side.
Comment 6 Jiri Rechtacek 2006-01-17 14:42:58 UTC
The problem is caused by a jdkbug in java/beans/NameGenerator.
java/beans/PropertyDescriptor uses NameGenerator to capitalize property name
when looking for read/write method. This bug was fixed in jdk1.6.
The problem appears only on Turkish locale, other locales works for me AFAIK.

Try run IDE on jdk6.0 beta (https://mustang.dev.java.net/) or with English locale.
Thanks

The second exception from addShortcut() method is tracked as issue 71389.
Comment 7 Marian Mirilovic 2006-02-09 10:00:25 UTC
*** Issue 72428 has been marked as a duplicate of this issue. ***
Comment 8 mahotr 2006-02-09 20:57:20 UTC
Everyone using WindowsXP or Linux OS with Turkish Locale settings should run 
netbeans with the argument(parameter, or whatever you name it) below

-locale tr_TR (For example, c:\netbeans\bin>netbeans.exe -locale tr_TR)

Or if you don't want to type it everytime you run netbeans, try adding it to 
the line below

netbeans_default_options="-J-Xms32m -J-Xmx128m -J-XX:PermSize=32m -J-
XX:MaxPermSize=96m -J-Xverify:none -J-Dapple.laf.useScreenMenuBar=true"

located in the file netbeans/etc/netbeans.conf

it should look like this,

netbeans_default_options="-J-Xms32m -J-Xmx128m -J-XX:PermSize=32m -J-
XX:MaxPermSize=96m -J-Xverify:none -J-Dapple.laf.useScreenMenuBar=true -locale 
tr_TR"

This should resolve the problem without changing the source code, using any 
beta version of the JDK 1.6 or changing the locale to English.

Best regards
Comment 9 Ken Frank 2006-02-09 21:29:44 UTC
just to clarify - does the -locale option described below work even if user
is running under Turkish locale on windows ? (but that its needed to work around
the jdk problem ?)

If not, then I think that it means users can't use some os specific features of
that locale ?

Also, when using -locale option, I don't think it extends to other processes
used or invoked by ide, 
like app server.

ken.frank@sun.com
Comment 10 mahotr 2006-02-09 22:43:42 UTC
"just to clarify - does the -locale option described below work even if user
is running under Turkish locale on windows ? (but that its needed to work 
around the jdk problem ?)"

I didn't try the -locale option with English or some other locale. While my 
system was set to Turkish locale, a NullPointerException was occuring while 
loading the ide. This option worked with Turkish locale on WindowsXP.

"Also, when using -locale option, I don't think it extends to other processes
used or invoked by ide, 
like app server."

That might be true, I never tried the app server with -locale option but I 
never had problems with Turkish locale while using app server before. But I 
will try to make some tests about this.
Comment 11 mahotr 2006-02-10 23:36:30 UTC
Hello everyone
I tried netbeans 5 this whole day to find some problems but so far no luck in
finding any. Well it is apparent that my simple tests would not be sufficient to
verify that by using -locale tr_TR option there will be no problems anymore. I
encountered another problem which seems related to the Turkish locale issue.
Windows version of Netbeans Mobility Pack installer gave me an error which
prevented me from installing it. After changing locale from Turkish to
English(USA) the installation completed without problem. I hope that new version
of Java (1.6) would prevent such issues.

My regards.
Comment 12 Jiri Prox 2006-03-06 13:07:27 UTC
*** Issue 73275 has been marked as a duplicate of this issue. ***
Comment 13 Marian Mirilovic 2006-10-12 09:13:03 UTC
*** Issue 74169 has been marked as a duplicate of this issue. ***
Comment 14 Marian Mirilovic 2006-10-12 09:18:22 UTC
verified
Comment 15 Marian Mirilovic 2006-10-12 09:22:52 UTC
*** Issue 74169 has been marked as a duplicate of this issue. ***
Comment 16 Marian Mirilovic 2006-10-12 09:23:03 UTC
*** Issue 74169 has been marked as a duplicate of this issue. ***
Comment 17 Marian Mirilovic 2006-10-12 09:32:12 UTC
*** Issue 86738 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo