Bug 71227 - [50cat] NB can't handle Win32 userdir when on a Windows UNC path
[50cat] NB can't handle Win32 userdir when on a Windows UNC path
Status: RESOLVED DUPLICATE of bug 46813
Product: platform
Classification: Unclassified
Component: Filesystems
5.x
PC Windows XP
: P3 (vote)
: 5.x
Assigned To: rmatous
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 11:59 UTC by ieising
Modified: 2008-12-22 22:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ieising 2006-01-10 11:59:58 UTC
[ BUILD # : 200601052030 ]
[ JDK VERSION : 1.5.0_06 ]

Hi,

I know this is an issue already brought up by me, but I feel that since it is known that NB can't handle this, it would be better for NB's image to provide the user with a message what is going on, what the implications are and how (s)he can solve this. This because it came up here at a clients, after me telling one of the co-developers how cool NB is and he started to laugh since the first thing after the admittedly cool splash was an exception.

Now the user is even provided with that this is a known issue, but no assurance about that there are no implications, nor how to solve this.
Also note, that although NB can't handle this, when I want to open a project, NB starts in the UNC, so I don't get the point in throwing this exception, since to me it doesn't seem to be an issue at all. Sofar no problems were faced even with the userdir on a UNC path.

Iwan

Annotation: ; might be because your user directory is on a Windows UNC path (issue #46813)? If so, try using mapped drive letters.
java.lang.IllegalArgumentException: URI has an authority component [file://vpnlfap00364/udv00364/Z714V34/.netbeans/5.0dev/emulators/wtk22_win/emulator/wtk22/docs/api/mmapi]
	at org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:48)
	at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:190)
	at org.openide.filesystems.FileUtil.isArchiveFile(FileUtil.java:1376)
	at org.netbeans.modules.kjava.j2meplatform.J2MEPlatform.resolveRelativePathToURL(J2MEPlatform.java:137)
	at org.netbeans.modules.kjava.j2meplatform.J2MEPlatform.resolveRelativePathToURLs(J2MEPlatform.java:116)
	at org.netbeans.modules.kjava.j2meplatform.J2MEPlatform.<init>(J2MEPlatform.java:86)
	at org.netbeans.modules.kjava.j2meplatform.PlatformConvertor$H.endElement(PlatformConvertor.java:517)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(AbstractSAXParser.java:633)
	at com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.endNamespaceScope(XMLDTDValidator.java:2108)
	at com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.handleEndElement(XMLDTDValidator.java:2059)
	at com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.endElement(XMLDTDValidator.java:932)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(XMLDocumentFragmentScannerImpl.java:1241)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(XMLDocumentFragmentScannerImpl.java:1685)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:368)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:834)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:148)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1242)
	at org.netbeans.modules.kjava.j2meplatform.PlatformConvertor.instanceCreate(PlatformConvertor.java:142)
	at org.netbeans.modules.java.platform.DefaultJavaPlatformProvider.getInstalledPlatforms(DefaultJavaPlatformProvider.java:61)
	at org.netbeans.modules.java.platform.DefaultJavaPlatformProvider.getDefaultPlatform(DefaultJavaPlatformProvider.java:91)
	at org.netbeans.api.java.platform.JavaPlatformManager.getDefaultPlatform(JavaPlatformManager.java:76)
	at org.netbeans.modules.java.j2seplatform.J2SEPlatformModule.updateSourceLevel(J2SEPlatformModule.java:59)
	at org.netbeans.modules.java.j2seplatform.J2SEPlatformModule.access$000(J2SEPlatformModule.java:31)
	at org.netbeans.modules.java.j2seplatform.J2SEPlatformModule$1.run(J2SEPlatformModule.java:46)
	at org.openide.util.Mutex.postRequest(Mutex.java:1113)
	at org.openide.util.Mutex.postWriteRequest(Mutex.java:483)
	at org.netbeans.modules.java.j2seplatform.J2SEPlatformModule.updateBuildProperties(J2SEPlatformModule.java:41)
	at org.netbeans.modules.java.j2seplatform.J2SEPlatformModule.restored(J2SEPlatformModule.java:36)
	at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:360)
	at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:276)
	at org.netbeans.ModuleManager.enable(ModuleManager.java:898)
	at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:377)
	at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:311)
	at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:244)
	at org.netbeans.core.startup.Main.getModuleSystem(Main.java:206)
	at org.netbeans.core.startup.Main.start(Main.java:377)
	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:90)
[catch] at java.lang.Thread.run(Thread.java:595)
Comment 1 Marian Mirilovic 2006-01-11 11:19:21 UTC
I've written your comments to issue 46813, so please do reply there, thanks in
advance.

*** This issue has been marked as a duplicate of 46813 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo