Bug 71197 - I18N - wrong encoding for Find & Search
I18N - wrong encoding for Find & Search
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Search
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Marian Petras
issues@utilities
: I18N
: 90661 (view as bug list)
Depends on: 97878
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-09 14:45 UTC by ale4349koc
Modified: 2007-05-25 19:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Issue 71197 examples in pictures (488.50 KB, application/octet-stream)
2007-01-16 05:59 UTC, ale4349koc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ale4349koc 2006-01-09 14:45:00 UTC
Hello, Dear NB Community!
I use NB 5.0-beta and used 4.1 & 3.6 before.
I had a hope that new NB version will do foreign language text search in project
and module, but it does not. When I do Edit-Find in Projects, enter any text in
Russian (my case) and push “Search” button, I received “No matching nodes were
found”, but they are exist in my code.
I think similar problem exist for other non-English languages.

Another problem is wrong encoding of non-English characters in Search Results
window, when in main window everything looks fine. I do search for some java
directive (out.println, for example), NB found all of them and show in Search
Results window, but Russian characters (comment for out.println in my case) are
not encoded correctly, whiles they look absolutely correct in main window.

Thanks for your attention
Sincerely
Alex
Comment 1 Miloslav Metelka 2006-06-09 16:09:35 UTC
I've tried to reproduce the problem with using Czech letters but Find in
Projects worked fine in the present dev build.
Reassigning to utilities/search for further evaluation.
Comment 2 Ken Frank 2006-07-13 23:33:08 UTC
Alex,

can you send more details and steps for each of the 2 things mentioned below,
also some gifs to show how the incorrect rendering of the Russian is ?
Also info on what platform(s) and locales on each will be helpful.

ken.frank@sun.com
Comment 3 Marian Petras 2007-01-15 14:12:40 UTC
This issue has already been reported as issue #79337 and I fixed it on 22
September 2006.

*** This issue has been marked as a duplicate of 79337 ***
Comment 4 ale4349koc 2007-01-15 19:20:42 UTC
Hello, guys
Sorry for too late response.
My environment is next:
-	I am working under Windows XP (Regional options standards – Russian, Location
– Russia, Default input Language – English (US), Additional keyboard Language –
Russian, Language for non-Unicode programs – Russian)
-	I am using NB 4.1 currently
-	I am programming Java and JSP modules with <%@page pageEncoding="UTF-8"%>

First problem is next: My Java and JSP contain the comments in Russian. When I
try to search some Russian text via “Edit-Find in Projects” NetBeans returns
correct search for Java classes, but does not show any occurrences of this text
in JSP modules. Everything works fine when I do search for English text.

Second problem is next: I have some Java code (for example String AIRA = "";   
   // код авиакомпании). The comment is in Russian. When I do “Edit-Find in
Projects” search for AIRA (not for Russian text), NetBeans found all lines with
this text and show in Search Results window. If AIRA text was found in Java
classes, Russian comment looks fine and readable. If AIRA text was found in JSP
modules the Russian comment is unreadable, because of wrong Encoding.

Probably it relates to <%@page pageEncoding="UTF-8"%>, which I am using for JSP.

Thanks for your attention and help.
Best wishes to all of you.
Alex
Comment 5 Ken Frank 2007-01-15 20:00:55 UTC
I think this might need to be entered as a new issue, since it seems the
bug that this one is marked as a duplicate of, 79337, has been fixed and verified
and seems to relate to java, not jsp.

Alex, I can enter a new issue on this as relates to jsp, using your comment
below as the text.  (unless you want to)

If you do, please mark as p2 and add the words I18N - to the summary line
as is shown in this issue.

And if you can then add a gif or jpg to that new issue, showing how the
ide looks when you see the problem, that will be helpful.

Thanks 

ken.frank@sun.com

Comment 6 ale4349koc 2007-01-16 05:59:56 UTC
Created attachment 37383 [details]
Issue 71197 examples in pictures
Comment 7 Marian Petras 2007-01-16 07:16:31 UTC
You are right that this issue is not an exact duplicate of bug #79337 (which is
only about Java files). So I reopened this issue.
Comment 8 Marian Petras 2007-01-16 07:17:52 UTC
This issue cannot be fixed until there is some API for obtaining information
about encoding of individual files. Issue 79337 is fixed because it uses an
unofficial API that works for Java files. The generic API should be added by
Milestone 7 of NetBeans 6.0 and I will then accomodate the search feature to use
it as soon as possible.
Comment 9 Marian Petras 2007-01-16 07:20:28 UTC
*** Issue 90661 has been marked as a duplicate of this issue. ***
Comment 11 Ken Frank 2007-05-25 19:58:14 UTC
Alex,

is this fixed ok for you now, using netbeans 6 milestone 9 build if possible ?

ken.frank@sun.com


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo