Bug 70870 - I18N - project with mbyte in name or dir path - javadoc does not show in browser
I18N - project with mbyte in name or dir path - javadoc does not show in browser
Status: RESOLVED DUPLICATE of bug 77798
Product: ide
Classification: Unclassified
Component: Extbrowser
5.x
Sun All
: P2 (vote)
: 5.x
Assigned To: Petr Pisl
issues@ide
: I18N, RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-31 02:08 UTC by Ken Frank
Modified: 2006-07-10 17:16 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
corrupted mbyte in browser address bart (6.77 KB, image/gif)
2005-12-31 02:09 UTC, Ken Frank
Details
correct view of mbyte in explorer and output window (104.58 KB, image/gif)
2005-12-31 02:10 UTC, Ken Frank
Details
another view of corrupted mbyte in browser (19.92 KB, image/gif)
2005-12-31 02:10 UTC, Ken Frank
Details
correct view of mbyte project name (74.74 KB, image/gif)
2005-12-31 02:11 UTC, Ken Frank
Details
Mozilla screenshot (40.49 KB, image/png)
2006-01-05 16:28 UTC, Marek Grummich
Details
In Swing Browser (64.71 KB, image/png)
2006-01-05 17:15 UTC, Petr Pisl
Details
Warning from Mozilla (27.85 KB, image/png)
2006-01-05 17:16 UTC, Petr Pisl
Details
Mozilla on Linux (52.22 KB, image/png)
2006-01-05 17:17 UTC, Petr Pisl
Details
Source window from mozilla. (80.10 KB, image/png)
2006-01-05 17:20 UTC, Petr Pisl
Details
Allert from Firefox (28.31 KB, image/png)
2006-01-05 17:41 UTC, Petr Pisl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2005-12-31 02:08:00 UTC
This is not issue related to localized nb. 

Run on solaris or windows in ja or zh locale.

create project with mbyte in first of its name (since this creates a dir
with mbyte, it might be that just having dir with mbyte might cause it).

choose generate javadoc from explorer menu

the javadoc is generated and it shows in output window the url that will be
used.

but on windows, the url is not found, since in windows address bar, the mbyte
its looking for is not correct - see gifs of that vs explorer/output window
view of project name/dir -- and it looks like the second ascii letter is
overwritten too.

on solaris, mozilla goes away when trying to browse to this incorrect url.

But if browse directly to the url shown in output window, its ok.

and if no mbyte is used, its ok.

No exceptions are seen in terminal or messages.log.
Comment 1 Ken Frank 2005-12-31 02:09:37 UTC
Created attachment 28111 [details]
corrupted mbyte in browser address bart
Comment 2 Ken Frank 2005-12-31 02:10:14 UTC
Created attachment 28112 [details]
correct view of mbyte in explorer and output window
Comment 3 Ken Frank 2005-12-31 02:10:52 UTC
Created attachment 28113 [details]
another view of corrupted mbyte in browser
Comment 4 Ken Frank 2005-12-31 02:11:23 UTC
Created attachment 28114 [details]
correct view of mbyte project name
Comment 5 Jan Becicka 2006-01-04 09:09:23 UTC
If I use internal swing browser, everything works correctly. The problem seems
to be in external browser module, which incorrectly translates internal url to
external one.
Comment 6 Marek Grummich 2006-01-05 16:28:17 UTC
Created attachment 28210 [details]
Mozilla screenshot
Comment 7 Marek Grummich 2006-01-05 16:32:09 UTC
Mozilla browser can show javadoc corretly. Look at the javadoc-mozilla
screenshot attachment. Character encoding was set Chinese simplified (GBK)
explicitly.
Comment 8 Petr Pisl 2006-01-05 17:15:21 UTC
Created attachment 28211 [details]
In Swing Browser
Comment 9 Petr Pisl 2006-01-05 17:16:14 UTC
Created attachment 28212 [details]
Warning from Mozilla
Comment 10 Petr Pisl 2006-01-05 17:17:14 UTC
Created attachment 28213 [details]
Mozilla on Linux
Comment 11 Petr Pisl 2006-01-05 17:20:55 UTC
Created attachment 28214 [details]
Source window from mozilla.
Comment 12 Petr Pisl 2006-01-05 17:41:48 UTC
Created attachment 28216 [details]
Allert from Firefox
Comment 13 Petr Pisl 2006-01-05 18:04:51 UTC
This is more complected then I thought at first time and I think that the bulk
of the problem lies outside NetBeans. It depends on the OS, encoding and browser.

What I discovered during evaluation:
1) Swing browser - works OK. It's because it's running in  the same VM -> the
same encoding has as NetBeans. You can see SwingBrowser.png
2) Mozilla on Linux - at first is displayed alert (mozilla-alert.png). But when
you click on ok, Mozilla start and show the left frame (mozila-window.png). So
the alert is not for the index page but for the second frame. You can see the
mozilla-source.png, where are not good the relative links. It's the reason, why
mozilla in this case is not able to open the second frame.
3) Mozilla on Windows - works correctly. Only Java doc doesn't generate the meta
tag with the needed encoding.
4) Firefox - see the alert from firefox (firefox.png). Firefox is not able
recognize the url, which is sand from NetBeans.

I don't really know what to do with this issue. This issue consists from more
problems. Fixing all these aspects it will be very dangerous for NB 5.0, and
still we are not able some small parts fix now. These problems were ther for
long time, so I suggest to wave this issue.
Comment 14 Petr Pisl 2006-01-10 17:32:23 UTC
The waiver was approved. Need to mention in documentation or rel. note.
Comment 15 Martin Krauskopf 2006-06-27 11:10:38 UTC
Huh, what's this. Why me? :) This module is part of ide cluster and as such,
this issue is not supposed to be fixed into 5.5, right?
Comment 16 Petr Jiricka 2006-06-27 12:05:07 UTC
Isn't this similar (or duplicate) of issue 77798 ?

Re targetting NB 5.5 or trunk: this should be fixed in NB 5.5, according to the
NB 5.5 quality criteria. This is code maintained by the J2EE team.
Comment 17 Petr Pisl 2006-07-10 17:16:32 UTC
I did again the evaluation and I still think as I wrote in January that this is
not connected with the NetBeans but with the browsers. The issue #77798 cover
exactly the same problem only the invocation is different. So I'm marking this
issue as duplicate of issue #77798.

*** This issue has been marked as a duplicate of 77798 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo