Bug 70280 - Review of actions work
Review of actions work
Status: RESOLVED DUPLICATE of bug 17597
Product: platform
Classification: Unclassified
Component: Actions
5.x
All All
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
: API_REVIEW
: 30581 (view as bug list)
Depends on: 62707 71242 71280 71515
Blocks: 89973
  Show dependency treegraph
 
Reported: 2005-12-12 15:54 UTC by Jaroslav Tulach
Modified: 2010-10-07 14:23 UTC (History)
10 users (show)

See Also:
Issue Type: TASK
:


Attachments
Initial Draft from Dec 12, 2005 (70.34 KB, text/html)
2005-12-13 10:06 UTC, Jaroslav Tulach
Details
The version of arch document as of 2005, Jan 10 (93.82 KB, text/html)
2006-01-10 11:32 UTC, Jaroslav Tulach
Details
Version of arch document from Jan31, 2006, that includes all review comments (94.69 KB, text/html)
2006-01-31 16:19 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2005-12-12 15:54:17 UTC
It seems that parts of the actions rework described in issue 17597 are a hot 
candidate for next version of NetBeans platform. That is definitely good as 
the current mixture of javax.swing.Action and org.openide.util.SystemAction 
creates rather unpleasant user experience. The main theme for the actions 
rework for 5.1 is: 
 
"Let's get rid of SystemAction" 
 
That does not necessarily mean we need to remove the action completely from 
all its usages, but an environment shall be created that new actions do not 
need to subclass SystemAction & co. at all and have other more pleasant 
alternatives.
Comment 1 Jaroslav Tulach 2005-12-12 15:58:33 UTC
The selected "voting" reviewers are:  
  
jjancura - for his recent experience with actions during New Options dialog  
msandor - for hard effort to write working CVS actions based on SystemAction  
mmetelka - for his insight into the way how editor actions work  
ppisl - for struggling with action definitions in layer and need to create new 
XML actions 
 
of course every reviewer is welcomed to join. I expect at least Jesse, Hrebejk 
and someone from debugger to participate as well. 
Comment 2 Jaroslav Tulach 2005-12-12 16:03:51 UTC
The initial step is to gather the requirements, formulate usecase and define 
the scope of the work for NetBeans 5.1 release. There is a living document 
that is going to reflect the opinion of submitter and reviewers at: 
 
http://www.netbeans.org/source/browse/openide/arch/arch-openide-actions.xml?rev=1.35.2&content-type=text/vnd.viewcvs-markup 
 
I'll attach its html version tomorrow, then the discussion can start. I'd like 
to have the inception review during early January 2006 and during it agree on 
the usecases and scope. I am looking forward to work with you. 
Comment 3 Jaroslav Tulach 2005-12-13 10:06:04 UTC
Created attachment 27782 [details]
Initial Draft from Dec 12, 2005
Comment 4 Jaroslav Tulach 2006-01-10 11:32:27 UTC
Created attachment 28332 [details]
The version of arch document as of 2005, Jan 10
Comment 5 Jaroslav Tulach 2006-01-16 09:46:46 UTC
Of some interest: A general overview page with a history of "actions effort": 
http://openide.netbeans.org/proposals/actions/index.html 
Comment 6 Jaroslav Tulach 2006-01-31 16:19:14 UTC
Created attachment 28679 [details]
Version of arch document from Jan31, 2006, that includes all review comments
Comment 7 Jaroslav Tulach 2006-01-31 16:25:12 UTC
The opinion is available at 
http://openide.netbeans.org/tutorial/reviews/opinions_70280.html 
Comment 8 Vitezslav Stejskal 2006-10-13 04:44:36 UTC
Just something to consider - issue #71280.
Comment 9 Antonin Nebuzelsky 2006-12-19 14:40:45 UTC
Currently not planned for 6.0.
Comment 10 Jaroslav Tulach 2008-07-17 22:08:43 UTC
Enough.

*** This issue has been marked as a duplicate of 17597 ***
Comment 11 Quality Engineering 2009-07-01 17:14:53 UTC
Integrated into 'main-golden', will be available in build *200907011400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/39a6cecbf6f7
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: Backporting the work done in CVS for actions #70280 into own branch in Hg
Comment 12 Jesse Glick 2010-10-07 14:23:28 UTC
*** Bug 30581 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo