Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 70258 - Allow to search also in excluded modules in Add module dep. dialog
Allow to search also in excluded modules in Add module dep. dialog
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
5.x
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Martin Kozeny
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-12 12:00 UTC by Tomas Danek
Modified: 2013-02-23 04:08 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2005-12-12 12:00:13 UTC
RFE from based on comment from issue 70127 :

have a checkbox in the Add Module Dependency dialog labelled something to the
effect of
"Display Excluded Modules" (default unchecked, and disabled if there are no
excluded modules/clusters in the target platform). If checked, modules (and
filter matches) even from modules currently excluded from the target platform
would be shown; if you tried to add a dep on such a module, you would first be
prompted to include that module in the app. (If it was disabled because its
whole cluster was excluded, the cluster would be un-excluded but all modules in
it except the new module would be excluded.)
Comment 1 Jesse Glick 2006-01-11 23:47:42 UTC
Please reevaluate - for 5.0u1, future, or leave TBD.
Comment 2 Martin Krauskopf 2008-02-07 17:49:28 UTC
I'm not working on APISupport anymore. Reassigning to owner of the component, so
the issue is not 'forgotten' forever.
Comment 3 Martin Kozeny 2013-02-20 09:03:41 UTC
https://hg.netbeans.org/core-main/rev/ccc2a055a3f8
Comment 4 Quality Engineering 2013-02-23 04:08:19 UTC
Integrated into 'main-golden', will be available in build *201302222300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b6c54f56ae17
User: Martin Kozeny <mkozeny@netbeans.org>
Log: #70258: To "Add Module Dependency" dialog is now added checkbox "Show Excluded Modules", which is disabled if there are no excluded modules from target platform or module is standalone, and if checked, modules excluded from target platform are shown and when any of these excluded modules is added to actual module, this or these excluded modules are then added to target platform. About adding excluded modules to target platform is user notified by confirmation dialog. If this action is not confirmed by the user, excluded module(s) is neither added to actual module, nor to target platform. In this commit is omitted adding modules from clusters excluded from target platform.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo