Bug 70219 - JUnit Results window gets activated at the end of tests
JUnit Results window gets activated at the end of tests
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: JUnit
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Marian Petras
junit-issues@java
: FOCUS, TEST, UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-11 18:15 UTC by Marian Petras
Modified: 2005-12-12 09:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2005-12-11 18:15:42 UTC
When all tests finish, the JUnit results window gets activated. It should not.
Comment 1 Marian Petras 2005-12-11 18:18:59 UTC
Will be fixed.
Comment 2 Marian Petras 2005-12-11 18:30:54 UTC
Fixed (in the trunk).

The cause was that I had unregistered (forgot) a JUnit Ant session before I sent
the last message to the results window. When the results window got the last
message, it probed the registry and found that the session is not registered -
and it was not. So the result window thought it was the _first_ message obtained
from the session and got activated.

A fixed this simply by moving the unregistration routine after the call that
sends the last message.

Modified file:
    junit/src/org/netbeans/modules/junit/output/Manager.java   (1.8)

Diff:
http://junit.netbeans.org/source/browse/junit/src/org/netbeans/modules/junit/output/Manager.java?r1=1.7&r2=1.8&diff_format=u
Comment 3 Jiri Skrivanek 2005-12-12 09:56:58 UTC
Verified. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo