Bug 70057 - Can't use Windows UNC path
Can't use Windows UNC path
Status: VERIFIED DUPLICATE of bug 46813
Product: platform
Classification: Unclassified
Component: Filesystems
5.x
PC Windows XP
: P3 (vote)
: 5.x
Assigned To: rmatous
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-08 04:11 UTC by dlong
Modified: 2008-12-22 19:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dlong 2005-12-08 04:11:41 UTC
Tried to use a UNC path (\\host\path) on Windows for a source folder, and got
the following exception:

java.lang.IllegalArgumentException: URI has an authority component
[file://Schuyler.sfbay]
	at
org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:48)
	at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:190)
	at
org.netbeans.modules.projectapi.SimpleFileOwnerQueryImplementation.uri2FileObject(SimpleFileOwnerQueryImplementation.java:177)
	at
org.netbeans.modules.projectapi.SimpleFileOwnerQueryImplementation.getOwner(SimpleFileOwnerQueryImplementation.java:52)
	at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:112)
	at
org.netbeans.modules.java.j2seproject.ui.wizards.FolderList$Renderer.getListCellRendererComponent(FolderList.java:266)
	at javax.swing.plaf.basic.BasicListUI.paintCell(BasicListUI.java:126)
	at javax.swing.plaf.basic.BasicListUI.paint(BasicListUI.java:215)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:142)
	at javax.swing.JComponent.paintComponent(JComponent.java:541)
	at javax.swing.JComponent.paint(JComponent.java:808)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at javax.swing.JViewport.paint(JViewport.java:722)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paint(JComponent.java:817)
	at javax.swing.JLayeredPane.paint(JLayeredPane.java:557)
	at javax.swing.JComponent.paintChildren(JComponent.java:647)
	at javax.swing.JComponent.paintWithOffscreenBuffer(JComponent.java:4794)
	at javax.swing.JComponent.paintDoubleBuffered(JComponent.java:4740)
	at javax.swing.JComponent.paint(JComponent.java:798)
	at java.awt.GraphicsCallback$PaintCallback.run(GraphicsCallback.java:21)
	at sun.awt.SunGraphicsCallback.runOneComponent(SunGraphicsCallback.java:60)
	at sun.awt.SunGraphicsCallback.runComponents(SunGraphicsCallback.java:97)
	at java.awt.Container.paint(Container.java:1312)
	at sun.awt.RepaintArea.paint(RepaintArea.java:177)
	at sun.awt.windows.WComponentPeer.handleEvent(WComponentPeer.java:260)
	at java.awt.Component.dispatchEventImpl(Component.java:3678)
	at java.awt.Container.dispatchEventImpl(Container.java:1627)
	at java.awt.Window.dispatchEventImpl(Window.java:1606)
	at java.awt.Component.dispatchEvent(Component.java:3477)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:141)
	at java.awt.Dialog$1.run(Dialog.java:540)
	at java.awt.Dialog.show(Dialog.java:561)
	at org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:800)
	at org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:843)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:831)
	at org.openide.util.Mutex.doEventAccess(Mutex.java:1146)
	at org.openide.util.Mutex.readAccess(Mutex.java:183)
	at org.netbeans.core.windows.services.NbPresenter.show(NbPresenter.java:816)
	at org.netbeans.core.NotifyException.updateState(NotifyException.java:297)
	at org.netbeans.core.NotifyException.access$400(NotifyException.java:55)
	at org.netbeans.core.NotifyException$2.run(NotifyException.java:228)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:141)
	at java.awt.Dialog$1.run(Dialog.java:540)
	at java.awt.Dialog.show(Dialog.java:561)
	at org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:800)
	at org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:843)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:831)
	at org.openide.util.Mutex$1.run(Mutex.java:1162)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Comment 1 rmatous 2005-12-10 14:06:29 UTC

*** This issue has been marked as a duplicate of 46813 ***
Comment 2 Marian Mirilovic 2006-01-10 12:52:56 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo