Bug 69498 - refactoring for field encapsulation & bean properties & property change & beaninfo
refactoring for field encapsulation & bean properties & property change & bea...
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
5.x
PC Windows XP
: P2 (vote)
: 7.2
Assigned To: Jan Becicka
issues@java
: PLAN
: 69671 139209 (view as bug list)
Depends on:
Blocks: 100758
  Show dependency treegraph
 
Reported: 2005-11-28 21:49 UTC by johnstosh
Modified: 2012-06-13 10:46 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Table showing which use case is supported by which feature (614 bytes, text/plain)
2011-11-28 11:20 UTC, Jan Becicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description johnstosh 2005-11-28 21:49:54 UTC
The tool at  Bean Patterns -> Add -> Property   in the "Projects" view is 
excellent.  This tool does a better refactoring than "Encapsulate fields ..." 
in that it supports firePropertyChange().  The "Encapsulate fields ..." 
refactoring, however, supports multiple properties at the same time.

Can we get all this functionality in one place?  Can you make it a view so it 
can show up as a tab?  Can you integrate it with the BeanInfo editor so that 
the bean information is updated when properties are added?
Comment 1 Jan Becicka 2005-11-29 08:25:54 UTC
I definitely agree -> but it is rather feature request.
Comment 2 Jan Becicka 2011-01-18 14:58:52 UTC
*** Bug 131693 has been marked as a duplicate of this bug. ***
Comment 3 Jan Becicka 2011-01-18 15:02:17 UTC
*** Bug 69671 has been marked as a duplicate of this bug. ***
Comment 4 Jan Becicka 2011-01-18 15:56:27 UTC
*** Bug 139209 has been marked as a duplicate of this bug. ***
Comment 5 Jan Becicka 2011-11-28 11:20:00 UTC
Created attachment 113571 [details]
Table showing which use case is supported by which feature
Comment 6 Jan Becicka 2011-12-08 10:04:05 UTC
Changeset: http://hg.netbeans.org/jet-main/rev/e40fd64c59b3
Author:    Jan Becicka <jbecicka@netbeans.org>
Date:      2011-12-08 10:52
Message:   PropertyChangeSuport for Encapsulate Fields
Issue #69498 - refactoring for field encapsulation & bean properties & property change & beaninfo
Comment 7 Quality Engineering 2011-12-10 12:05:17 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/e40fd64c59b3
User: Jan Becicka <jbecicka@netbeans.org>
Log: PropertyChangeSuport for Encapsulate Fields
Issue #69498 - refactoring for field encapsulation & bean properties & property change & beaninfo
Comment 8 Jan Becicka 2012-01-23 09:42:58 UTC
Changeset: 1d09b83e02ee
Author:    Jan Becicka <jbecicka@netbeans.org>
Date:      2012-01-23 10:39
Message:   
Issue #69498 - refactoring for field encapsulation & bean properties & property change & beaninfo
Comment 9 Quality Engineering 2012-01-25 16:30:21 UTC
Integrated into 'main-golden', will be available in build *201201250600* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1d09b83e02ee
User: Jan Becicka <jbecicka@netbeans.org>
Log: Issue #69498 - refactoring for field encapsulation & bean properties & property change & beaninfo


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo