Bug 69179 - Sometimes key input in text dialog field doesn't display
Sometimes key input in text dialog field doesn't display
Status: VERIFIED DUPLICATE of bug 50423
Product: platform
Classification: Unclassified
Component: Window System
5.x
PC Linux
: P3 (vote)
: 5.x
Assigned To: David Simonek
issues@platform
: FOCUS
Depends on: 60656
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 13:40 UTC by fordfrog
Modified: 2008-12-22 16:50 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fordfrog 2005-11-23 13:40:26 UTC
It happens quite often to me that when I open a dialog window (it happens to me
in various dialog windows) and try to write some keys into single-line text
field (it displays caret in it so I do not use mouse to set focus to the field)
they don't display. I have found out that if I click with mouse to another text
control, the output of the buffer holding the keys is flushed into the text
field I set focus to.
I use 200511221900 daily build but it happens to me since the time I begun to
use nb (about 2 weeks) so I cannot tell whether it behaved some other way before.
Comment 1 Marian Mirilovic 2005-11-23 15:23:46 UTC
Could you be more specific? Please write a list of dialogs, where you can
encounter this problem. Also please add your JDK version. Thanks in advance.
Comment 2 fordfrog 2005-11-23 15:54:59 UTC
Sorry for incompletness. Here is a simple procedure:
1) create property resource file and add some locales (I have en and cs)
2) open the resource file for editing in tabular view (not source)
3) press New Property a start input some characters (if it works the first time
- it did right now when I try it - then just close the dialog and press New
Propertye again)
4) when no input displays though you pressed some keys, click mouse to Value or
Comment field - buffered characters should be flushed into the field you clicked
(if you press Esc during "hidden input" period, the click to another field
causes closing of the dialog)

I remember this also happened when I was adding new library through Library
Manager (Project pane -> Libraries -> Properties -> Add Library -> Manage
Libraries -> New Library -> try input)

I have tested these both dialogs to be sure the bug occurs (it did). There might
be more dialogs that suffer with this problem but I'm not sure where else it
occured.

My JDK is "Sun JDK 1.5.0.05".
Comment 3 David Simonek 2005-11-24 11:16:33 UTC
Thanks fordfrog.

Marian could you please try to reproduce on Linux? I smell another JDK bug due
to the nature of occurence, so please try to test both jdk 1.5 and mustang, it
may even be already fixed on JDK side. 

Also jtulach, I remember you were dealign with similar issue long time ago?
Comment 4 David Simonek 2005-11-24 11:57:43 UTC
Btw, this issue is very similar to 60656, although reproduction steps differ.
Comment 5 Jaroslav Tulach 2005-11-25 07:45:43 UTC

*** This issue has been marked as a duplicate of 50423 ***
Comment 6 Marian Mirilovic 2005-11-25 09:33:53 UTC
It looks like it's really the JDK bug. It's also marked as fixed for Mustang
(build 53). SO if you want, wait for the build or try to use:

-Dnetbeans.hack.50423=true to enable reflection based workaround 
for the type ahead problem

verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo