Bug 68936 - [50cat] Accelerator keys in the Output window are inconsistent with rest of NetBeans
[50cat] Accelerator keys in the Output window are inconsistent with rest of N...
Status: RESOLVED DUPLICATE of bug 96190
Product: platform
Classification: Unclassified
Component: Output Window
5.x
All All
: P3 (vote)
: 6.x
Assigned To: t_h
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-18 14:59 UTC by dkkopp
Modified: 2009-03-09 16:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dkkopp 2005-11-18 14:59:20 UTC
[ JDK VERSION : 1.5.0_05 ]

On the Mac, the Wrap test accellerator is Command W. This is also the command to close a window. It would be better if the accelerator was Command T.

Also, to be consistent with OS X's terminal window, the Clear accellerator should be Command K.

I would change these myself, but I cannot find anywhere in the Keymap to do it.
Comment 1 dkkopp 2005-11-18 15:05:11 UTC
I have also filed issue 68937 about the Keymap
Comment 2 Milos Kleint 2005-12-05 08:40:41 UTC
to allow user changes of output window shortcuts is not likely fixable in 5.0
timeframe, requires a rewrite of the action support in the output window.

I could manually force the MacOSX specific keybindings. However that has effect
on documentation.
Comment 3 dkkopp 2005-12-06 13:58:43 UTC
I agree that this should be pushed off to the next release. Forcing OS X 
bindings would just confuse everyone at this point.
Comment 4 Max Sauer 2006-09-27 12:32:39 UTC
Can we synchronise the keyboard shotcuts with IDE settings (Options|Keymap) at
least for 6.0? It is really annoyoing for users with different keymap (ie. Emacs
shortcuts).

---
NetBeans IDE Dev (Build 060927)
1.6.0-rc; Java HotSpot(TM) Server VM 1.6.0-rc-b99
Linux version 2.6.12-1.1390_FC4smp running on i386
en_US (nb); UTF-8
retouche build NetBeans-dev-060927.zip
Comment 5 Antonin Nebuzelsky 2008-02-07 15:53:09 UTC
Reassigning to new module owner Tomas Holy.
Comment 6 t_h 2009-03-09 16:46:47 UTC

*** This issue has been marked as a duplicate of 96190 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo