Bug 68716 - check during building project if the module is enabled in platform
check during building project if the module is enabled in platform
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Harness
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Jesse Glick
issues@apisupport
:
Depends on: 59792
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 10:24 UTC by pzajac
Modified: 2010-02-03 22:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2005-11-15 10:24:35 UTC
Steps to reproduce:
1) Create a module suite
2) Add a module project to the module suite 
3) Add FileSystemsAPI to the module project
4) Add a class which uses FileSystemAPI
5) Disable the FileSystemAPI in the module suite's customizer
6) Compile the module project

The project is compiled successfully. It is wrong because the module project
depends on FileSystemsAPI. The FileSystemsAPI were removed from platform. So the
compiling of the module project should fail with appropropriate message
(org-openide-filesystems.jar is not presented in module suite's platform).
Comment 1 Jesse Glick 2005-11-15 18:46:14 UTC
Too complicated for 5.0. And may be better handled at the GUI layer rather than
in the Ant build; TBD.
Comment 2 Jesse Glick 2005-12-30 07:51:42 UTC
Fixed as part of issue #59792.
Comment 3 pzajac 2006-01-19 10:34:39 UTC
verified
Comment 4 Quality Engineering 2010-02-03 22:00:26 UTC
Integrated into 'main-golden', will be available in build *201002040200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ad91b4ecf23c
User: Jesse Glick <jglick@netbeans.org>
Log: Refixing #68716, apparently broken by cluster.path refactoring.
Caught by CompilationDependencyTest.testCompileAgainstRemovedModule68716.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo