Bug 68388 - [50cat] Dialogs do not get focus automatically
[50cat] Dialogs do not get focus automatically
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
5.x
PC Solaris
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: FOCUS, RANDOM
: 70666 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-09 15:22 UTC by vanob
Modified: 2008-12-22 10:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vanob 2005-11-09 15:22:23 UTC
[ BUILD # : 200511081900 ]
[ JDK VERSION : 1.5.0_05 ]

This is the general issue. Just work with ide
and you will notice that often Dialogs (Find,Goto Line, New Class, etc...) do not get focus when invoked and you have to do it manually. As requested 
I'm providing details of my system. I will add more details on demand.

CPU: AMD 64
Video: NVIDIA GeForce 5200 (binary nvidia driver)
OS: Solaris Express 10/05 on amd 64
DE: Java Desktop System for Solaris
Comment 1 David Simonek 2005-11-09 16:06:29 UTC
Passing to Standa to try reproduce on Solaris.
This error is probably specific to JDS, maybe bug in JDS/JDK itself, no such
problems on Linux, Win, Mac.

vanob, could you please try to play for a while with SwingSet2 demo (in jdk
installation) or with simple swing app which opens dialog from the frame to see
if error is reproductible only in netbeans or in all apps.  

Also downgrading to P3, as this bug occurs randomly. 
Comment 2 vanob 2005-11-09 21:20:32 UTC
dsimonek

I played with SwingSet2 Demo, also played with other java application
called SQL Workbench but could not reproduce the problem at all.
For example SQL Workbench also has the editor and if you press Ctrl+F it invokes
the find dialog. I pressed Ctrl+F  and Esc several times (about 10) and all the
time the dialog had the focus while in NetBeans I can reproduce the problem in
maximum 3 incokations. I don't agree that this bug is random. It's reproducible
always in my configuration within 5 attempts. But I don't change the priority
because Solaris OS should not need to be the showstopper of the release I guess.
Comment 3 Stanislav Aubrecht 2005-11-30 17:06:28 UTC
cannot reproduce on solaris 5.10 (sun ultra-60), CDE, jdk 1.5 
Comment 4 Jiri Rechtacek 2005-12-22 08:00:46 UTC
*** Issue 70666 has been marked as a duplicate of this issue. ***
Comment 5 Stanislav Aubrecht 2007-10-31 16:26:52 UTC
cannot reproduce - closing

please reopen if you can provide reliable steps to reproduce
Comment 6 vanob 2007-10-31 17:31:10 UTC
Now I'm using SXDE 9/07 with jdk 6 update 2 without this issue.
I'll reopen if it happens.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo