Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 67774 - [50cat] enhancement for editor hover-type java doc pop-up or hint:
[50cat] enhancement for editor hover-type java doc pop-up or hint:
Status: RESOLVED DUPLICATE of bug 95691
Product: editor
Classification: Unclassified
Component: -- Other --
5.x
PC Windows XP
: P3 with 1 vote (vote)
: TBD
Assigned To: Milutin Kristofic
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-29 21:05 UTC by kalali
Modified: 2013-02-03 17:41 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kalali 2005-10-29 21:05:45 UTC
[ JDK VERSION : 1.5.0_03 ]

There should be a hover to show javadoc pop-up for a type.
it means that when i put the mouse over a variable of some type it let me to use 
Shift+mouse hover to show the javadoc pop-up or some hint.
but the hint shold allow user to change it to javadoc pop-up by pressing for example CTRL+Shift+F12
Comment 1 swpalmer 2012-01-30 19:11:58 UTC
My colleagues that use Eclipse have been begging for this feature.
While browsing code they don't want to leave the mouse, and use the keyboard to pop up javadocs.

Hovering isn't used at all yet in the NetBeans editor.  This would be a good use of it.
Comment 2 dharkness 2012-06-28 22:23:24 UTC
This works great for PHP code, displaying the PHPDoc for a class/method/property when you CTRL + Hover over it.

It should work the same for Java code. It's annoying that you have to place the caret into the word and hit CTRL + SHIFT + Space to see the JavaDoc.
Comment 3 markiewb 2013-02-03 17:41:11 UTC
Duplicate of 95691. Please vote there.

*** This bug has been marked as a duplicate of bug 95691 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo