Bug 67530 - Corrupted VPD registry database
Corrupted VPD registry database
Status: RESOLVED WONTFIX
Product: installer
Classification: Unclassified
Component: Code
5.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: mslama
issues@installer
: RELNOTE
: 68967 69398 71618 71679 71819 84041 88648 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-26 01:01 UTC by francoca
Modified: 2007-06-27 09:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
This is the stop to the installer (50.05 KB, image/jpeg)
2005-10-26 01:18 UTC, francoca
Details
A short of the error reported (61.01 KB, image/jpeg)
2005-10-28 13:58 UTC, francoca
Details
The logfile from installer launched with -is:log (97.29 KB, text/plain)
2005-10-28 13:59 UTC, francoca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description francoca 2005-10-26 01:01:50 UTC
First, sorry for my elementary english
Hi,

aftrer a failed installation I can't install any netbeans 5 on my windows XP, 
after I lounch the Installer it display an error like:

"Welcome to the install Wizard for ERROR: null"

more after the Installer stops and no Istallation can do.

Thanks
Comment 1 francoca 2005-10-26 01:18:36 UTC
Created attachment 26335 [details]
This is the stop to the installer
Comment 2 mslama 2005-10-26 08:50:21 UTC
It is weird error. Make sure no other installer is running (reboot OS). Make
sure your installer is not corrupted. Check md5sum with value given at download
page.
Comment 3 francoca 2005-10-26 17:36:49 UTC
No luck,

I've rebooted and tried to install many time, also I reinstalled J2sdk but 
nothing.

Md5sum is good and the installation file works good on another machine, also 
NetBeans 4.1 will install properly, only the Netbeans 5.0 not.

There is not a switch to start Installer in debug mode or something like?

thanks in advance.
Comment 4 mslama 2005-10-26 19:57:17 UTC
You can run installer from console with command line option -is:extract. It will
unzip setup.jar to subdir. Then you can run java -jar setup.jar from console.
You should get detailed install log to console. You can also add -Dis.debug=1
after java: java -Dis.debug=1 -jar setup.jar to get more detailed debug log from
Install Shield. To get log from installer launcher (before JVM is started) you
can use -is:log <Log file> as parameter for exe. (But from your report I assume
problem arises in JVM.)
Comment 5 francoca 2005-10-28 13:57:11 UTC
Wath delusion!

I spent days of my life to some null!

I'm unable to install netbeans 5.0, i tried to reinstall JDK many time but 
nothing.

NetBeans 4.1 works fine, but my projects converted to 5.0 not.

Can anyone help me??

Can the logfile of installation help??

Ciao
Comment 6 francoca 2005-10-28 13:58:35 UTC
Created attachment 26426 [details]
A short of the error reported
Comment 7 francoca 2005-10-28 13:59:27 UTC
Created attachment 26427 [details]
The logfile from installer launched with -is:log
Comment 8 mslama 2005-10-31 07:29:26 UTC
Please first check md5 checksum with value given at download page. (If you give
me exact installer build you use I can give you md5 checksum here.) It looks
like installer is corrupted. You can use zip distribution as workaround.
Comment 9 mslama 2005-10-31 07:36:38 UTC
You can get utility to compute md5 checksum for Windows for example at
http://www.pc-tools.net/win32/md5sums/.
Comment 10 francoca 2005-11-02 10:03:31 UTC
There is the installer:
netbeans-5_0-daily-bin-200510261858-windows-26_Oct_2005_1858.exe

and this is the md5 calculated on my two different workstation:
63B5E100A1A1BB09604F41DF33290DD4

Thank. 
Comment 11 mslama 2005-11-02 10:25:22 UTC
Your md5sum is correct. My is the same 63b5e100a1a1bb09604f41df33290dd4. So
please try to extract setup.jar and run it from console if you get something more:
jar -Dis.debug=1 -Dtemp.dir=<Path to any temp dir> -jar setup.jar

Error message about VPD registry usage means that there is probably another
instance of installer running in background. Use task manager to check if there
is another java process running.
Comment 12 francoca 2005-11-02 14:33:08 UTC
First, sorry for my elementary english.
Hi, good work!

Your 'VPD registry' phrase has done me the right way, the problem was 
InstallShield hitself, moving temporarely the "C:\program files\Common 
files\InstallShield" directory into another place permits to the NetBeans 
installer to works fine, so I can see that it create a directory called Gen1 
into the "C:\program files\Common files\InstallShield\Universal\Common" that 
once removed, fix the entire problem.

Thank You a lot,

Franco
Comment 13 Michal Mocnak 2005-11-03 14:38:49 UTC
Verified
Comment 14 mslama 2005-11-29 10:05:13 UTC
*** Issue 68967 has been marked as a duplicate of this issue. ***
Comment 15 mslama 2005-11-30 08:27:55 UTC
*** Issue 69398 has been marked as a duplicate of this issue. ***
Comment 16 mslama 2006-01-24 19:29:26 UTC
Actually not fixed. There is only workaround: Delete content of C:\program
files\Common files\InstallShield\Universal\Common dir on Windows or
$HOME/InstallShield/Universal/Common dir on Linux/Solaris.
Comment 17 mslama 2006-01-25 08:49:03 UTC
*** Issue 71819 has been marked as a duplicate of this issue. ***
Comment 18 mslama 2006-01-25 08:51:45 UTC
Please what version of Windows do you use? English?
Comment 19 mslama 2006-01-26 18:15:50 UTC
*** Issue 71679 has been marked as a duplicate of this issue. ***
Comment 20 mslama 2006-06-21 08:35:31 UTC
Closing as WONTFIX. It is problem in InstallShield infrastructure so we cannot
fix it anyhow.
Comment 21 mslama 2006-06-21 09:31:45 UTC
*** Issue 71618 has been marked as a duplicate of this issue. ***
Comment 22 mslama 2006-09-13 09:37:02 UTC
*** Issue 84041 has been marked as a duplicate of this issue. ***
Comment 23 mslama 2006-11-08 08:51:26 UTC
*** Issue 88648 has been marked as a duplicate of this issue. ***
Comment 24 edburns 2007-06-27 08:47:48 UTC
Thank you so much for fixing this.  I'm here at Jazoon in Switzerland and I have been pulling my hair out over my 
inability to install netbeans to get my demo ready.  PLEASE, can you make it so when I search for 

"ERROR: null Installer" 

in the top level NetBeans search, I see a hit for this bug?

Thanks,

Ed
Comment 25 mslama 2007-06-27 09:00:33 UTC
Use Google and search for "ERROR: null Installer NetBeans". This problem is described in installation instructions,
troubleshooting section.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo