Bug 67397 - Provide feature to reformat all sources of project
Provide feature to reformat all sources of project
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All All
: P2 with 5 votes (vote)
: 7.2
Assigned To: Dusan Balek
issues@editor
:
: 125051 201564 209370 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-24 10:19 UTC by Vladimir Yaroslavskiy
Modified: 2013-12-18 22:28 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Yaroslavskiy 2005-10-24 10:19:51 UTC
Provide feature to reformat all sources of project, not only one current opened
file in editor. It takes a lot of time to open all classes one by one and
reformat it.
Comment 1 rocky 2007-05-21 13:37:15 UTC
I would prefer this to act like the PMD plugin: running it on a file does just
that file, but you can also run it on a node in the project window using
right-click, Tools. This lets you apply formating to individual classes,
packages or directories.
Comment 2 hoijui 2010-04-13 20:59:10 UTC
I missed this functionality in multiple project already. Right now, i started to work in a new project with around 500 java source files. Most of them are quite ugly:
* using spaces before tabs in the indentation
* being inconsistent in brackets usage within files
...

This could be an alternative, until it is supported by Netbeans its self:
http://sourceforge.net/projects/jalopy/
though the comments seem to suggest it currently does not work with NB.
Comment 3 Jan Lahoda 2012-02-10 14:11:06 UTC
The Source/Format action should work on packages, folders, source groups and projects after:
http://hg.netbeans.org/jet-main/rev/4c9f73dec36b
Comment 4 hoijui 2012-02-18 19:26:12 UTC
nice! thanks! :-)
looking forward to test this in the next release with a few libraries.
Comment 5 soldatov 2012-03-11 11:43:33 UTC
*** Bug 209370 has been marked as a duplicate of this bug. ***
Comment 6 markiewb 2013-12-18 22:04:42 UTC
*** Bug 125051 has been marked as a duplicate of this bug. ***
Comment 7 markiewb 2013-12-18 22:28:55 UTC
*** Bug 201564 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo