Bug 66860 - [50cat] Unable to "Add to registry" from webservices node of IDE (blocking)
[50cat] Unable to "Add to registry" from webservices node of IDE (blocking)
Status: VERIFIED FIXED
Product: usersguide
Classification: Unclassified
Component: Web Services
5.x
All All
: P2 with 1 vote (vote)
: 5.x
Assigned To: Geertjan Wielenga
issues@webservices
: RELNOTE
: 66411 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 23:47 UTC by balajir
Modified: 2006-03-21 16:29 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description balajir 2005-10-14 23:47:25 UTC
Build: Netbeans 5.0 build dated 10/12/2005 

Build and Deploy a webservice in to the SJSAS 8.0 UR2 App. Server. 
Now try "Adding to Registry" using the webservices node under
the webservice project. 

THe following error message keeps showing up even though the
App. server is confirmed to be running. 

"Unable to add web service to registry. Make sure it is deployed,
the server is running and the correct WSDL was entered" 

I verified that the wsdl was accessinble through the http://localhost:8080
and can see the WSDL page. This proves that the WSDL was deployed
and the server is running. However "Adding to registry" fails even
after multiple attempts. 

Due to this the WS client cannot be developed to access the service. 
I am unable to test the added WS operations due to this problem.
Comment 1 _ pcw 2005-10-18 00:41:49 UTC
I checked Balaji's install of NetBeans and the webservices registry module
failed to initialize (displayed w/ red X and message "Press F1 for help"), but
there were no messages in the log.  Also, when F1 was pressed, the IDE window
disppeared and we had to kill the NB process via TaskManager (this is bad, IMO).
 So the problem here is solved by figuring out why the registry did not
initialize.  He had spaces in both the NetBeans install dir and user dir paths,
so I asked him to install a second copy that did not do either and try that.  In
the meantime, I'm going to test a similar install (w/ the spaces, etc.) and see
if I can reproduce the problem.  It could also be a path length issue somewhere
(this was on Windows XP).
Comment 2 _ pcw 2005-10-18 01:13:29 UTC
Disregard previous comment, this problem is independent of spaces in any paths.

I was able reproduce this problem with my recent personal dev build by running
on JDK 1.4.2 (rev. 05).  Balagi was using rev. 09, so that portion probably
doesn't matter.

Raising priority to P2.
Comment 3 _ pcw 2005-10-18 01:32:02 UTC
I noticed that the description for an invalid registry node indicates that when
running under JDK 1.4.2, an additional XML library is needed, so this is why the
node is broken.  I'm leaving this as an open P2 though, for two reasons:

1) This description message is only visible if you can view properties on the
node.  But (a) there is no popup menu provided on the disabled node, so no quick
access to properties and (b) you can view properties globally by using Windows |
Properties, then reselected the disabled web service registry node, but no
customer is going to do that.  I only did it AFTER I'd seen the text in the
source code bundle.

2) F1 for help killed the NB window (but not NB - weird) on Balaji's machine. 
On my machine, I got the message "[org.netbeans.modules.javahelp] Warning: the
JavaHelp topic ID org.netbeans.modules.websvc.registry.netbeans.WebServices
RootNodeInterface was not found." twice in the console window, so there is a bug
here wrt/ help.

3) At least for dev builds, there is no JAXRPC-16 library on the dev update
center. (It is there when running 5.0 beta though.)  Not sure how important this
problem is, but as a dev build user, I have no idea right now how to obtain this
library, so I can't test under 1.4.2.

I think the solution for this problem needs to be far more visible.  Otherwise
it'll be a support nightmare when 5.0 is released.
Comment 4 clever 2005-10-20 03:32:18 UTC
*** Issue 66411 has been marked as a duplicate of this issue. ***
Comment 5 clever 2005-10-20 03:34:34 UTC
I think this definitely needs a cleaner solution.  We can't move to JDK 1.5
because it breaks some integration projects.  Maybe the web service supporting
module can indicate the missing libs when F1 is hit.  if I remember, hitting F1
does absolutely nothing useful right now anyway.

This should be cleaned up before release.
Comment 6 Lukas Jungmann 2005-10-20 10:01:41 UTC
rnovak, could you put JAXRPC-16 library also on dev update center, please? For
more info see #3 in last pcw's comment. Thanks.
Comment 7 Milan Kuchtiak 2005-10-21 08:16:30 UTC
This should be also announced in Release notes:
Install the JAXRPC-16 library to enable the WS support in JDK 1.4.2

The good news is that you don't need to have the SJS application server
installed for WS clients in java project and for WS Registry.
Comment 8 _ pcw 2005-10-21 18:33:02 UTC
See also my #2 above.  Ignore the "F1 killed NB" comment, it was a workspace
switcher the user had installed.  But the invalid help context bug has to be
fixed by release.  If we show text that says "Hit F1", hitting F1 w/ that node
selected has to take the user directly to the explanation on how to fix it.
Comment 9 Milan Kuchtiak 2005-11-01 14:26:39 UTC
Seams that JAXRPC-16 library exists on dev update center.

Changed text for disabled WS Registry node to :
"Web Services[disabled]-press F1 for help"
See :
http://websvc.netbeans.org/source/browse/websvc/registry/src/org/netbeans/modules/websvc/registry/netbeans/Bundle.properties?r1=1.8&r2=1.9

Geertjan, please, implement the Help Id for
org.netbeans.modules.websvc.registry.netbeans.WebServicesRootNodeInterface
and mention the problem in Realease Notes.
Comment 10 Geertjan Wielenga 2005-11-15 15:37:33 UTC
Fixed. Please verify.

Comment 11 Geertjan Wielenga 2005-11-15 15:47:41 UTC
I've also passed on this text to Talley, to put in the Release Notes:

"If you use JDK 1.4.2 and you want to work with web services, install the
JAXRPC-16 library from the Update Center."

Please verify that this is correct.
Comment 12 Lukas Jungmann 2006-03-21 16:29:50 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo