Bug 66652 - Change continue shortcut from Ctrl+F5 to F5
Change continue shortcut from Ctrl+F5 to F5
Status: CLOSED DUPLICATE of bug 90133
Product: debugger
Classification: Unclassified
Component: Code
5.x
All All
: P2 (vote)
: 6.x
Assigned To: jrojcek
issues@debugger
: UI
Depends on: 90133
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-12 18:38 UTC by Martin Entlicher
Modified: 2008-04-25 12:35 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2005-10-12 18:38:30 UTC
As reported at nbusers@netbeans.org:

Continue is used much more often then start debugging. But Start debugging is F5
and continue is CTRL-F5. Therefore it would be better to swap these shortcuts.
Comment 1 Martin Entlicher 2005-10-12 18:41:20 UTC
Jano, can you please consider this change?
Comment 2 fuerte 2005-10-12 21:53:30 UTC
How about F5 starts debugging and also continues, as happens in other debuggers
I have used to (Visual Studio). It does not (usually) make much sense to start
another debugging session when you have one already running.
Comment 3 teyc 2006-08-14 04:46:33 UTC
fuerte is correct. I prefer for F5 key-bindings to have two meanings:
1) When program is running, F5 means continue
2) When program isn't, F5 means Start process
Comment 4 Martin Entlicher 2006-12-02 00:27:17 UTC
There is an associated issue #90133. We can change the shortcut according to the
resolution of issue #90133.
Comment 5 Petr Cyhelsky 2008-04-16 15:31:02 UTC
The reason for the issue is fixed, if there are other issues with shortcuts in debugger see issue #90133 (especially the
third post)

*** This issue has been marked as a duplicate of 90133 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo