Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 66559 - [50cat] Editor window freezes (Mac OS X)
[50cat] Editor window freezes (Mac OS X)
Status: VERIFIED DUPLICATE of bug 60235
Product: editor
Classification: Unclassified
Component: -- Other --
5.x
Macintosh Mac OS X
: P2 (vote)
: 5.x
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-12 08:34 UTC by lordy
Modified: 2007-11-05 13:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (9.10 KB, text/plain)
2005-10-12 09:25 UTC, lordy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lordy 2005-10-12 08:34:26 UTC
[ BUILD # : 200510111800 ]
[ JDK VERSION : 1.5.0_05 ]

i test 200510100858 after issue 61971 should be fixed. But i 
have still problem which freezes the editor. But maybe this is 
new:

* i get a hint from the editor like "import java.awt.Component"
* i press enter key on keyboard

all work fine. But:

* i get a hint from the editor like "import java.awt.Component"
* i click with the mouse on it

editor window freezes.
Comment 1 Martin Roskanin 2005-10-12 08:48:35 UTC
I cannot reproduce it on winXP, could you please attach a full thread dump? Thanks
Comment 2 lordy 2005-10-12 09:25:15 UTC
Created attachment 25839 [details]
thread dump
Comment 3 Martin Roskanin 2005-10-12 09:37:29 UTC
It seems, there is no deadlock in the thread dump you have attached. Did you
take the thread dump during the "editor window freeze"?
Comment 4 lordy 2005-10-12 10:02:50 UTC
yes, i dit it during the "editor window freeze". But it think "editor window freeze" is maybe the wrong 
describtion:

after:
* i get a hint from the editor like "import java.awt.Component"
* i click with the mouse on it

i have no curser in editor windows. Also when i switch to other open files, i have no curser in this. But i 
can select text, invoke popup menu and copy the selected text. But i can't edit anything i select.

Oh, i try it know with 1.4.2_09 on Mac OS X and there no problems. So i hope another Mac User can 
reproduce it with 1.5.0_05
Comment 5 Miloslav Metelka 2005-10-12 10:52:20 UTC
This in fact a duplicate of issue 60235. Until that one gets resolved please try
one of the workarounds e.g. opening and closing of the Find dialog or switching
to external app.

*** This issue has been marked as a duplicate of 60235 ***
Comment 6 Milos Kleint 2005-10-12 11:01:54 UTC
more likely a duplicate of #65326, #60235 is more like an umbrella issue for
anything focus related on maxosx+jdk 1.5
Comment 7 lordy 2006-01-18 18:57:11 UTC
verified against netbeans 5.0 rc1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo