Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 65959 - [50cat] Missing settings in Modern view of Options dialog
[50cat] Missing settings in Modern view of Options dialog
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Code
5.x
All All
: P1 with 2 votes (vote)
: 6.x
Assigned To: issues@ide
issues@ide
issue_reviewed
:
: 65964 66863 (view as bug list)
Depends on: 63993 64655
Blocks: 90522
  Show dependency treegraph
 
Reported: 2005-10-05 13:25 UTC by Roman Strobl
Modified: 2010-04-20 09:25 UTC (History)
10 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Strobl 2005-10-05 13:25:11 UTC
This is an issue whose purpose is to keep track of all missing options in the
modern view of the Options dialog. The goal is to create a list of options which
are important and exist only in the classic view. Please add your missing
options to the list with a short explanation. I will summarize the feedback we
got so far now.
Comment 1 misterm 2005-10-05 13:33:08 UTC
- Collaboration settings;
- Editing -> XML -> General Settings -> Automatic Parsing Delay &
Short Empty Element;
- Editing -> Editor Settings -> Code folding, Delay of Completion
Window Auto Popup, Line Numbers, Text Limit Character Count;
- Editing -> Java Sources -> Automatic Parsing Delay;
- Update Center-related settings
Comment 2 misterm 2005-10-05 13:34:40 UTC
Adding the magic prefix for consistency.
Comment 3 Roman Strobl 2005-10-05 13:39:25 UTC
The other options people miss are:

- text limit line color - some people want to change the color

- web browser path - necessary when user has more browsers of the same type
Comment 4 wulgar 2005-10-05 13:44:57 UTC
Editor settings --> Java Editor --> Tab Size
Comment 5 Roman Strobl 2005-10-05 13:45:54 UTC
- tab size - user cannot set the tab size if he doesn't want to use spaces
instead of tabs
Comment 6 misterm 2005-10-05 15:12:36 UTC
Roman asked me to explain why I use the settings I suggested, so here we go:

- Collaboration settings:
I usually increase timeout and Notification settings

- Editing -> XML -> General Settings -> Automatic Parsing Delay:
I usually decrease it

- Editing -> XML -> General Settings -> Short Empty Element:
I mark it as true/false depending on the project I'm working on

- Editing -> Editor Settings -> Code folding:
I usually mark initial comments/imports as collapsed by default, but for some 
projects initial comments are relevant and then I make it not collapsed.

- Editing -> Editor Settings -> Delay of Completion:
I decrease this.

- Editing -> Editor Settings -> Window Auto Popup:
I decrase this.

- Editing -> Editor Settings -> Line Numbers:
Mark it as true

- Editing -> Editor Settings -> Text Limit Character Count:
Change it according to project conventions

- Editing -> Java Sources -> Automatic Parsing Delay:
I decrease it

- Update Center-related settings:
I change the check for update frequency (daily), change the URL for update 
centers sometimes and add some of them manually.
Comment 7 gholmer 2005-10-05 16:34:36 UTC
1) turn on line numbers in editor 
2) line height correction in editor (save screen space) 
3) print settings (even current OD is not good): 
http://www.netbeans.org/issues/show_bug.cgi?id=65275 
4) indentation/space vs. tab 
5) display text limit line/color, text limit character count 
 
Comment 8 wulgar 2005-10-06 07:10:52 UTC
- Encoding of java files
In my project sources is UTF-8
Comment 9 Jan Jancura 2005-10-06 08:12:34 UTC
*** Issue 65964 has been marked as a duplicate of this issue. ***
Comment 10 gholmer 2005-10-06 23:34:58 UTC
Also, ability to add object types, e.g. adding Velocity templates (.vm) as HTML
so you can get code completion.
Comment 11 marcpaes 2005-10-08 21:38:21 UTC
I miss

1 - All the code completion options
     Case Sensitive, Show Javadoc, Delay of auto completion popup etc

2 - Line Numbers
Comment 12 Michel Graciano 2005-10-12 17:15:18 UTC
- Editing -> Java Sources -> String Tables:
I always set developer name

- Editing -> Java Sources -> Override Methods -> Return Generation Mode:
I usually set Generate Exception
Comment 13 trembovetski 2005-10-12 23:08:21 UTC
A must have setting from the old dialog for me is the ability
to disable the blinking cursor. Die, blinking cursor, die!

Dmitri
Java2D Team
Comment 14 vbrabant 2005-10-12 23:40:40 UTC
Concerning the Update-Center related settings, why not move it to the Update
Center Wizard. On that Wizard, we already have the Proxy Configuration button.

Seems logic to have access to those options through this wizard.

Also, when you use the classic view to change the configuration of the proxy,
it's less convivial than when you use the Proxy Configuration button of the Wizard.

IMHO, the Proxy entry point of the Modern View would be replaced by just a Proxy
Configuration button that call the same dialog box than then one used for the
Update Center Wizard. 

------------------------


Comment 15 vbrabant 2005-10-13 01:16:29 UTC
Also other comments about the Modern View 

1. Concerning the General Section, 
     - why the Proxy settings is not a button like in the Update Center Wizard.
So, you will win space for other General Options :-)
     - Would be nice to keep the Confirm Deletion, show File Extension (i like
to see File extension) and Ignored files for versionning 

2. Concerning the Editor Section,
    - General tab should contains only stuffs that is for General purpose. It's
a non-sense for me to propose Collapse by default Methods, Inner Classes,
Imports, JavaDoc Comments, ... in general tab, when those options are concerning
only Java Editor, maybe also JSP Editor, but not XML nor properties, ...
    Also, impossible to handle the delay of completion window Auto Popup, as
before, or the automatic parsing delay (never understood why it was in Editing |
XML | general setting and Editing | Java Source, and not in Editing | Editor
Settings | XML Editor and Editing | Editor Settings | Java Editor.
    IMHO, in Editor | General Tab, I would like to see the Show Toolbar
property, the Line numbering, the insert point blink rate, insert point blink
color, Insertion point, Overwrite carret, Line height correction (Do you know
about people that will change those properties per type of editor ? Really ?),
Status bar delay, Status bar visible, Display text limit line, Text limit
character count. (to discuss. Could be by editor)

    Idem for Code Completion. Code Completion is certainly case sensitive for
xml or xhtml, or jsp xml, but could not be case sensitive for jsp, html, java, ...

    - Indentation tab: should also be associated to a given editor, as before. I
mean: In XML, I don't want that a new line is added when I type a { or that a
space is added when I type parenthesis. Leading Star in comments are only
concerning Java & JSP.


     No special remarks for Code Templates and Macros. Except that if they are
existing in the Modern View, they would be removed from the Classic View.

     If someone could explain me why the Form Editor settings are in the
Advanced section, and not in the Editor section. That is also annoying. 

3. Fonts & Color 
     - Impossible to change Fonts & Colors for the SQL Editor through the modern
 view. 
     - Impossible to change Colors for the Form Editor through the modern view.

     - Impossible to indicate other Fonts & Colors Rules When you will print the
text.
     - How to modify colors used by Merge and Diff tools ?

     - highlight Tab: Text limit line color would appears in that list.

     - Annotation tab: What's the difference between Parser Annotation (red
cross) and Parser Annotation (yellow). Also, why to do a difference between
Parser Annotation and JSP Parser Annotation, or Error and XML Syntax Error.

4. KeyMap: Nothing to say. 

5. Advanced
    - Advanced has a totally different look and feel than other section. Any
reason why ?
    - Not yet a Ant Home Manager !!!
    - Form Editor would be moved to Editor Section.
    - would be nice to have the TODO Settings 
    - How can I associate a PDF Document Objects to a PDF Viewer ?
    - How can I associate extension / mimetype to a Object Type ?
Comment 16 Kenneth Ganfield 2005-10-17 10:40:09 UTC
yes, TODO configuration would be good under Advanced.

Will Internationalization go back into Advnaced in Modern View?
Comment 17 Jan Jancura 2006-08-11 11:06:05 UTC
*** Issue 66863 has been marked as a duplicate of this issue. ***
Comment 18 Jesse Glick 2006-12-12 14:48:51 UTC
Generally I think there should still be an advanced option page but it should
show the content of NbPreferences and look like "about:config" in Firefox. This
would permit rarely used or experimental preferences to be made visible in the
GUI somehow (for people who know they really want them), without any significant
development effort per preference.

"turn on line numbers in editor" - available from context menu of editor window.

"Encoding of Java files" - probably better handled using a quite different
system (already are RFEs open for this).

"ability to add object types" - really this means "ability to customize MIME
resolvers", I think (cf. current thread on nbdev)

"Concerning the Update-Center related settings, why not move it to the Update
Center Wizard." - yes indeed, that is where it should be.

"Not yet a Ant Home Manager" - that does not exist at all currently; if you want
it, it's a separate RFE in the ant module.

Seems that no one even mentioned customization of the contents of toolbars and
menus. Perhaps no one (besides me) does this? :-) May be enough to ensure that
all reasonable menu and toolbar items appear in the appropriate locations but
are marked with a "hidden" flag of some sort by default if they are not to be
shown; a customizer would then simply let you check or uncheck preselected items.
Comment 19 rmatous 2006-12-20 14:31:22 UTC
NbPreferences keeps just information about preferences that were modified and
doesn't know the ultimate list of preferences.

Thus not easy to implement UI sheet containing all preferences that would look
like "about:config". Declarative defaults for NbPreferences could help but not
accepted during review process - maybe we could reevaluate it again. Declarative
defaults would be very helpful also for sharing preferences among modules
because although you can share preferences, you cannot share their defaults
(e.g. Ignored files in IDESettings). 
Comment 20 rmatous 2006-12-20 15:27:00 UTC
I think that module owners should make decision which settings should be
presented to user and how (whether to choose AdvancedOption, OptionsCategory or
 be part of "about:config" sheet). 

In other words individual module owners should provide UI specs(individual
issues should be filled) and when all are ready someone from HIE should review
it as a whole. Any objections against such process ?
Comment 21 Peter Pis 2008-08-22 07:27:18 UTC
Any progress on this?
Comment 22 a7ndrew 2009-03-11 05:29:50 UTC
Absolutely agree with Dmitri, cursor blink should be EASY to turn off.
Comment 23 Marian Mirilovic 2010-04-20 09:25:06 UTC
This was general issue right after rewrite of Options, for now doesn't make any sense to keep it opened. If anybody finds any setting is missing please report it as separate issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo