Bug 65872 - [50cat] Editor does not get focus after opening file from projects view
[50cat] Editor does not get focus after opening file from projects view
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
5.x
PC Solaris
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: A11Y, FOCUS, RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-04 15:47 UTC by vanob
Modified: 2008-12-22 10:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vanob 2005-10-04 15:47:17 UTC
[ BUILD # : 200509261930 ]
[ JDK VERSION : 1.5.0_05 ]

1. Start with empty usedir
2. Open some project
3. Press Ctrl+1
4. type some letters. A little edit box appears
and the class name is highlited as you type. when some class is selected press enter.
5. The class is opened in the editor but the focus
remains in the projects view.

This bug is not always reproducible. I think when the big class is opened the editor analyzes it and does not receive focus.
Comment 1 Marian Mirilovic 2005-10-04 16:30:41 UTC
I can reproduce this NB5.0(200510031800), JDK 6.0 (b54), Linux RH9/Gnome ...

It looks like the editor is active/selected but the focus is still in the tree,
you can move selection in the Projects view although the Projects view isn't
selected ... 
I have to say it's annoying and it would be nice to solve this for NB5.0 ...

There is something strange, after short investigation I can't reproduce it ;(
Comment 2 David Simonek 2005-10-27 13:08:06 UTC
Whoa, I can reproduce too on my Win XP. 100% reproductible for me if editor
which is opening after Enter key is the very first one, I mean that only Welcome
window is in editor area.
Comment 3 Marian Mirilovic 2006-01-03 10:54:10 UTC
Too late for NB5.0, please reevaluate.
Comment 4 David Simonek 2007-09-24 13:11:11 UTC
Passing to Standa...
Comment 5 Stanislav Aubrecht 2007-09-25 15:24:19 UTC
fixed

/cvs/openide/explorer/src/org/openide/explorer/view/TreeView.java,v  <--  TreeView.java
new revision: 1.26; previous revision: 1.25


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo