Bug 65762 - [50cat] DB Explorer should warn that the value of the Size column cannot be zero for a VARCHAR
[50cat] DB Explorer should warn that the value of the Size column cannot be z...
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
5.x
PC All
: P2 (vote)
: 7.3
Assigned To: Jiri Rechtacek
issues@db
:
: 78487 78895 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-03 21:32 UTC by vbrabant
Modified: 2013-01-10 14:33 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Error because of selection of VARCHAR (15.32 KB, image/jpeg)
2005-10-03 21:32 UTC, vbrabant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vbrabant 2005-10-03 21:32:17 UTC
[ BUILD # : Beta ]
[ JDK VERSION : 1.5.0_05 ]

[I am using the Derby Engine.]

If I choose a Varchar as DataType during creation of a table, I receive the following error:

Unable to execute command
create table "APP"."MyClass" ( "ID" SMALLINT not null primary key, "FIRST_NAME" VARCHAR ) 

See screenshot in attach.
Comment 1 vbrabant 2005-10-03 21:32:51 UTC
Created attachment 25474 [details]
Error because of selection of VARCHAR
Comment 2 Andrei Badea 2005-10-04 10:48:35 UTC
Not a defect. VARCHAR in Derby must be specified using a length, like in
VARCHAR(length), thus you must enter a non-zero number in the Size column. 

Maybe the DB Explorer should warn that the value of the Size column cannot be
zero, if you feel so please file a RFE.
Comment 3 vbrabant 2005-10-14 22:22:11 UTC
So, I reopened that issue, as a enhancement and modified the title.
Hope it's ok.
Comment 4 Petr Blaha 2006-03-13 13:32:21 UTC
TM 5.0 -> TBD
Comment 5 Andrei Badea 2006-06-22 15:45:01 UTC
*** Issue 78487 has been marked as a duplicate of this issue. ***
Comment 6 Andrei Badea 2006-06-22 15:45:57 UTC
So maybe it deserves a higher priority.
Comment 7 Andrei Badea 2006-06-22 16:13:17 UTC
*** Issue 78895 has been marked as a duplicate of this issue. ***
Comment 8 Jiri Rechtacek 2009-10-16 14:03:03 UTC
Reassigned to new owner.
Comment 9 Jaroslav Havlin 2013-01-10 14:33:06 UTC
The value (length) is validated in NetBeans 7.3.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo