Bug 65351 - [50cat] NB Freezes after update center and tools options selection
[50cat] NB Freezes after update center and tools options selection
Status: RESOLVED WORKSFORME
Product: editor
Classification: Unclassified
Component: Options
5.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 14:23 UTC by claudio4j
Modified: 2007-11-05 13:40 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot 1 (72.39 KB, image/png)
2005-09-29 14:26 UTC, claudio4j
Details
screenshot 2 (28.44 KB, image/png)
2005-09-29 14:28 UTC, claudio4j
Details

Note You need to log in before you can comment on or make changes to this bug.
Description claudio4j 2005-09-29 14:23:50 UTC
[ JDK VERSION : 1.6 ]

Yesterday, right after installed (with a clean user dir) used update center, and Tools --> option , NetBeans (5 beta)  have freeze, see the steps below.

1) Install NB 5 beta and run NB
1) Selected some update center modules 
2) After finished, and "turning off modules...done" message displayed on status bar, go Tools --> Options
3) Status bar displays "loading options..."  together with progress bar
4) At Editor Option, select "macro" and "Code template" tab, there were no one option at drop-down list, screenshot 1
5) selected "ok" or "cancel" button
   at this time the "loading options..."  status bar message and progress bar is on, yet. screenshot 2
6) Exit NetBeans, File --> Exit
7) Progress bar and "Loading Options" status bar message continues to show, but NetBeans freezes.

	I did those steps two times, the freeze is reproducible.

See my system

  Product Version       = NetBeans IDE 5.0 Beta (Build 200509261930)
  Operating System      = Linux version 2.6.11.7-mh2 running on i386
  Java; VM; Vendor      = 1.6.0-ea; Java HotSpot(TM) Client VM 1.6.0-ea-b53; Sun Microsystems Inc.
  Java Home             = /usr/local/j2se/sun/jdk1.6.0/jre
  System Locale; Encod. = pt_BR (nb); ISO-8859-15

	Strange, there were no exception at .netbeans/5.0beta/var/log/messages
Comment 1 claudio4j 2005-09-29 14:26:32 UTC
Created attachment 25302 [details]
screenshot 1
Comment 2 claudio4j 2005-09-29 14:28:50 UTC
Created attachment 25303 [details]
screenshot 2
Comment 3 claudio4j 2005-09-29 15:03:16 UTC
I tried to see the thread dump: kill -3 PID, no results...

I killed the process, kill PID

Started again, go to Tools --> Options, them "Negative value is not allowd" (ok,
known bug), the exit, options, go to Tools --> Options again, everything now
shows to be fine (code template and macros)

Then I removed netbeans install and user dir (rm -rf ~/.netbeans
~/javaSoftware/netbeans*)

Installed NB again and started, updated modules, when modules installment ends,
exit netbeans.

started NB again, go to tools --> options, it shows "negative value is not
allowed"  (known bug, ok), then Editor option --> "macro" and "code template"
shows the 1st screenshot, drop down list, shows no values, go to cancel button,
then got back to tools --> Options , everythin shows fine now.

To let you know, the selected modules
  Derby
  CVS Profile
  JMX

and marked all of them "Global" and "Yes to all"
Comment 4 Jan Chalupa 2005-09-29 21:20:31 UTC
Known editor/options issue?
Comment 5 claudio4j 2005-09-30 04:24:37 UTC
The bug I refer, when I wrote "go to tools --> options, it shows "negative value
is not allowed"  (known bug, ok)" 

http://www.netbeans.org/issues/show_bug.cgi?id=64597
Comment 6 Jan Jancura 2005-10-07 08:54:20 UTC
I will look at it.
Comment 7 Jan Jancura 2006-01-03 09:02:11 UTC
Too late to fix in nb5.0.
Comment 8 Vitezslav Stejskal 2006-12-04 10:37:54 UTC
I am sorry, but I could not reproduce this. I installed some global modules from
AU, restarted Netbeans and Tools-Options showed up nicely after that. Without
the full thread dump the chances for catching this deadlock are pretty low.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo