Bug 65190 - I18N - Don't hardcode preferredSize for inner panels in customizer
I18N - Don't hardcode preferredSize for inner panels in customizer
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Milos Kleint
issues@projects
OSLO
: A11Y, I18N, UI
: 65761 71980 88786 (view as bug list)
Depends on:
Blocks: 64780 71312 84134
  Show dependency treegraph
 
Reported: 2005-09-27 14:24 UTC by Martin Krauskopf
Modified: 2007-10-22 17:12 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
project-ui-api.diff (4.75 KB, patch)
2005-09-27 14:25 UTC, Martin Krauskopf
Details | Diff
apisupport.diff (9.01 KB, patch)
2005-09-27 14:26 UTC, Martin Krauskopf
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Krauskopf 2005-09-27 14:24:32 UTC
o.n.m.project.uiapi.CustomizerPanel has hardcoded preferred size to 750x450.
Then it is not easily possible (or impossible at all) to change *dynamically*
size of the customizer which could be the reason of I18N problems like in issue
64780. Note that setting just bigger size of the dialog received from
o.n.spi.project.ui.support.ProjectCustomizer.createCustomizerDialog() doesn't
solve the problem since you can't predict the final font (i.e. Chinesse,
Arabic), size of images in customizers, etc.
So it would be nice to have a possibility to say that you don't want the
predefined preferred size and so give the implementator chance to control this
himself. Of better provides some satisfactory API for such tasks.
Adding an example, simple working patch together with patch for
apisupport/project customizers. Please consider something like this. (or course,
ideal would be to move as much of code as possible to the project-ui-api)
Comment 1 Martin Krauskopf 2005-09-27 14:25:34 UTC
Created attachment 25226 [details]
project-ui-api.diff
Comment 2 Martin Krauskopf 2005-09-27 14:26:19 UTC
Created attachment 25227 [details]
apisupport.diff
Comment 3 Ken Frank 2005-09-27 17:03:29 UTC
added I18N to synopsis for tracking.

ken.frank@sun.com
Comment 4 Jan Lahoda 2005-10-27 10:09:16 UTC
*** Issue 65761 has been marked as a duplicate of this issue. ***
Comment 5 Martin Krauskopf 2006-01-30 10:11:41 UTC
*** Issue 71980 has been marked as a duplicate of this issue. ***
Comment 6 Martin Krauskopf 2006-08-15 16:59:27 UTC
Increasing to P2, see Ken's comment in the issue #64780 which is blocked by this
one.
Comment 7 Milan Kubec 2006-09-14 09:22:05 UTC
Will look at it for post 5.5 release.
Comment 8 Martin Krauskopf 2006-11-08 05:30:32 UTC
*** Issue 88786 has been marked as a duplicate of this issue. ***
Comment 9 Milos Kleint 2007-01-11 13:18:34 UTC
instead of setting the fixed size, check the calculated size of the panel and
just do a boundary check (750x450 being the minimal and 850x550 the maximum
size). Can be overriden by the users of te customizer api by setting the
dialog's prefferedSize/Size

Checking in CustomizerPane.form;
/cvs/projects/projectuiapi/src/org/netbeans/modules/project/uiapi/CustomizerPane.form,v
 <--  CustomizerPane.form
new revision: 1.4; previous revision: 1.3
done
Checking in CustomizerPane.java;
/cvs/projects/projectuiapi/src/org/netbeans/modules/project/uiapi/CustomizerPane.java,v
 <--  CustomizerPane.java
new revision: 1.7; previous revision: 1.6
done
Comment 10 Ken Frank 2007-05-27 02:54:02 UTC
Where/which window/dialog in ide did this situation happen  ?  I'd like to
verify the fix.

ken.frank@sun.com
Comment 11 Jaromir Uhrik 2007-10-22 09:40:02 UTC
Ken, this issue is related to panels that are inside of Project Properties dialog which can be invoked by selecting
Properties in popup menu on any project node in Projects view. Could you please verify this issue. Thanks.
Comment 12 Ken Frank 2007-10-22 17:12:43 UTC
I think I need to be more clear on what panels inside of project props dialog - if it means any parts
of project props, I don't think it can be verified here since this fix was done we have seen various
resize problems in various project props windows of different products, and have filed them in those
projects and most have been fixed specifically in those projects.

So it might be that this fix helped some situations to begin with but it seems other layout and coding
are needed in any given project props window to ensure about resizing.

ken.frank@sun.com


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo