Bug 65097 - [50cat] Deadlock while closing modified file
[50cat] Deadlock while closing modified file
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Text
5.x
PC Windows XP
: P3 (vote)
: 5.x
Assigned To: Jaroslav Tulach
issues@platform
: THREAD
: 65183 65226 65248 65252 65611 67063 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 07:38 UTC by wulgar
Modified: 2008-12-22 19:50 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wulgar 2005-09-26 07:38:44 UTC
[ BUILD # : 200509251800 ]
[ JDK VERSION : 1.5.0_05 ]

See attachment.

java.lang.InterruptedException: Waiting 10s for AWT and nothing! Exiting to prevent deadlock
	at org.openide.text.CloneableEditorSupport$1SafeAWTAccess.waitForResult(CloneableEditorSupport.java:1028)
	at org.openide.text.CloneableEditorSupport.canClose(CloneableEditorSupport.java:1041)
	at org.openide.text.DataEditorSupport.canClose(DataEditorSupport.java:274)
	at org.openide.text.CloneableEditor.closeLast(CloneableEditor.java:328)
	at org.openide.windows.CloneableTopComponent$Ref.unregister(CloneableTopComponent.java:330)
	at org.openide.windows.CloneableTopComponent$Ref.access$300(CloneableTopComponent.java:222)
	at org.openide.windows.CloneableTopComponent.canClose(CloneableTopComponent.java:174)
	at org.openide.text.CloneableEditor.canClose(CloneableEditor.java:136)
	at org.netbeans.core.windows.Central.removeModeTopComponent(Central.java:725)
	at org.netbeans.core.windows.Central.userClosedTopComponent(Central.java:1535)
	at org.netbeans.core.windows.view.DefaultView.userClosedTopComponent(DefaultView.java:724)
	at org.netbeans.core.windows.view.ui.TabbedHandler.actionPerformed(TabbedHandler.java:292)
	at org.netbeans.swing.tabcontrol.TabbedContainer.postActionEvent(TabbedContainer.java:664)
	at org.netbeans.swing.tabcontrol.TabbedContainerUI.shouldPerformAction(TabbedContainerUI.java:134)
	at org.netbeans.swing.tabcontrol.plaf.DefaultTabbedContainerUI.access$2600(DefaultTabbedContainerUI.java:80)
	at org.netbeans.swing.tabcontrol.plaf.DefaultTabbedContainerUI$DisplayerActionListener.actionPerformed(DefaultTabbedContainerUI.java:1229)
	at org.netbeans.swing.tabcontrol.TabDisplayer.postActionEvent(TabDisplayer.java:513)
	at org.netbeans.swing.tabcontrol.TabDisplayerUI.shouldPerformAction(TabDisplayerUI.java:144)
	at org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI.access$1500(BasicTabDisplayerUI.java:74)
	at org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI$BasicDisplayerMouseListener.performCommand(BasicTabDisplayerUI.java:689)
	at org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI$BasicDisplayerMouseListener.potentialCommand(BasicTabDisplayerUI.java:674)
	at org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI$BasicDisplayerMouseListener.mouseReleased(BasicTabDisplayerUI.java:722)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)
	at java.awt.Component.processMouseEvent(Component.java:5488)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Martin Roskanin 2005-09-26 14:56:22 UTC
Reassigning to openide/editor
If the deadlock really occured, please attach full thread dump. Thanks.
Comment 2 Marian Mirilovic 2005-09-27 09:06:53 UTC
BTW: it's nice check for deadlock ;)
Comment 3 Petr Nejedly 2005-09-27 10:32:17 UTC
Yarda's "fix".
Waiting from inside AWT for invokeLater ;-)
Comment 4 Jaroslav Tulach 2005-09-27 12:04:39 UTC
/cvs/openide/text/src/org/openide/text/CloneableEditorSupport.java,v  <--  
CloneableEditorSupport.java 
new revision: 1.8; previous revision: 1.7 
done 
Checking in 
text/test/unit/src/org/openide/text/DocumentCannotBeClosedWhenAWTBlockedTest.java; 
/cvs/openide/text/test/unit/src/org/openide/text/DocumentCannotBeClosedWhenAWTBlockedTest.java,v  
<--  DocumentCannotBeClosedWhenAWTBlockedTest.java 
new revision: 1.3; previous revision: 1.2 
 
Comment 5 Petr Nejedly 2005-09-27 13:19:51 UTC
*** Issue 65183 has been marked as a duplicate of this issue. ***
Comment 6 Martin Roskanin 2005-09-29 09:13:47 UTC
*** Issue 65252 has been marked as a duplicate of this issue. ***
Comment 7 Martin Roskanin 2005-09-29 09:21:05 UTC
*** Issue 65226 has been marked as a duplicate of this issue. ***
Comment 8 Petr Nejedly 2005-09-29 13:17:32 UTC
*** Issue 65248 has been marked as a duplicate of this issue. ***
Comment 9 Martin Roskanin 2005-10-11 14:23:03 UTC
*** Issue 65611 has been marked as a duplicate of this issue. ***
Comment 10 Jan Chalupa 2005-10-19 15:16:32 UTC
*** Issue 67063 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo