Bug 65030 - "Add New..." menu item for Modules node under a suite
"Add New..." menu item for Modules node under a suite
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Martin Krauskopf
issues@apisupport
http://apisupport.netbeans.org/51m1-u...
: UI
: 66067 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-23 18:53 UTC by Jesse Glick
Modified: 2006-01-18 17:11 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-09-23 18:53:55 UTC
It would make sense to let the user create and add a new module from the suite
context menu, so I am adding this to the UI spec. Need not happen for 5.0 however.
Comment 1 Jesse Glick 2005-10-07 22:52:41 UTC
*** Issue 66067 has been marked as a duplicate of this issue. ***
Comment 2 Martin Krauskopf 2005-12-13 05:23:37 UTC
This one should be relatively easy.
Comment 3 Martin Krauskopf 2006-01-08 10:36:34 UTC
Fixed. Wizard, invoked from the added context menu (see URL), runs in a pure
"Suite Component Mode" locked to the context suite only.
Maybe some additions somewhere to the documentation will be needed? (Geertjan is
already CCed). 

Checking in ui/Bundle.properties; 1.24 -> 1.25;
Checking in ui/SuiteLogicalView.java; 1.22 -> 1.23;
Checking in ui/wizard/BasicInfoVisualPanel.java; 1.47 -> 1.48;
Checking in ui/wizard/BasicVisualPanel.java; 1.11 -> 1.12;
Checking in ui/wizard/BasicWizardPanel.java; 1.8 -> 1.9;
Checking in ui/wizard/NewNbModuleWizardIterator.java; 1.26 -> 1.27;
Comment 4 Jesse Glick 2006-01-08 18:57:59 UTC
Looks good. I will just swap the order of the menu items to match the spec. (Add
New... will be used more than Add Existing..., I am presuming.)
Comment 5 Martin Krauskopf 2006-01-08 19:21:39 UTC
> I will just swap the order of the menu items to match the spec.

"You will" or "You would". So who should do it? :)
Comment 6 Jesse Glick 2006-01-08 19:41:52 UTC
I will do it.
Comment 7 pzajac 2006-01-18 15:52:45 UTC
Verified. Add Library wrapper item in "Modules Popup" will be also nice...
Comment 8 Martin Krauskopf 2006-01-18 17:11:51 UTC
> Add Library wrapper item in "Modules Popup" would be also nice..

issue 71056 :)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo