Bug 64991 - Permit project command actions to be enabled on multiselections
Permit project command actions to be enabled on multiselections
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
4.x
All All
: P3 (vote)
: 7.2
Assigned To: Jesse Glick
issues@projects
: UI
: 108962 118363 120548 (view as bug list)
Depends on: 71515 209765
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-23 13:10 UTC by drscott
Modified: 2012-03-24 11:06 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description drscott 2005-09-23 13:10:02 UTC
I have to handle many Web-projects simultaniously. Unfortunately, some actions
cannot applied to all open projects at once (as it is with 'Find' for example):

Clean all(selected) projects
Build all(selected) projects
Deploy all(selected) projects

CVS actions on all projects (it is very annoying to have to select all those cvs
nodes in the Files view first...)

Maybe there are more actions for which this enhancement could be useful.
Comment 1 Marian Mirilovic 2006-01-22 10:55:41 UTC
File a separate enhancement against javacvs component regarding CVS actions, please.
Comment 2 Jesse Glick 2006-01-22 17:02:35 UTC
You could

1. Wrap the WARs in an EAR, if that makes sense, in which case it ought to clean
and build them all at once if asked. This is what is normally done. The EAR
project could be the main project, in which case F11 & S-F11 also work.

2. Use a freeform project to hold an Ant script to clean and build them all at
once, or whatever you like. Can also use a "bare" Ant script somewhere - can
make a shortcut from one of its targets.

3. Use the experimental Project Groups module on Auto Update for development
builds. Add the projects to a group and then run e.g. Build on it.

BTW it is not possible to implement safely without an API change, since running
these actions in parallel is dangerous - see issue #71515.
Comment 3 Jesse Glick 2007-07-09 21:02:31 UTC
*** Issue 108962 has been marked as a duplicate of this issue. ***
Comment 4 Jesse Glick 2007-10-10 14:08:02 UTC
*** Issue 118363 has been marked as a duplicate of this issue. ***
Comment 5 tomzi 2007-10-12 07:19:11 UTC
any hope for this one?
Comment 6 Jesse Glick 2007-10-30 21:51:25 UTC
*** Issue 120548 has been marked as a duplicate of this issue. ***
Comment 7 Jesse Glick 2012-03-20 14:47:58 UTC
core-main #6a6ce17eff08
Comment 8 Quality Engineering 2012-03-24 11:06:27 UTC
Integrated into 'main-golden', will be available in build *201203240400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6a6ce17eff08
User: Jesse Glick <jglick@netbeans.org>
Log: #64991: permit project command actions to be enabled on multiselections.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo