Bug 64612 - [50cat] Branding application: Icon (*.icn) of windows-launcher(*.exe)
[50cat] Branding application: Icon (*.icn) of windows-launcher(*.exe)
Status: RESOLVED WONTFIX
Product: apisupport
Classification: Unclassified
Component: Harness
5.x
PC Windows ME/2000
: P3 with 8 votes (vote)
: TBD
Assigned To: Martin Kozeny
issues@apisupport
http://stackoverflow.com/questions/86...
:
: 79235 83287 118066 136365 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-18 18:14 UTC by lordy
Modified: 2014-03-31 22:34 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lordy 2005-09-18 18:14:54 UTC
[ BUILD # : 200509151800 ]
[ JDK VERSION : 1.5.0_02 ]

The Icon which set in "Basic Branding" in the Project Properties 
Dialog should also use for the windows-launcher.

I research about the topic a little and found many problems that 
must solve for this issue.

First of all the icn support. I only found Jimi(http://
java.sun.com/products/jimi/) for icn support. But i think the jre 
also must support icn for Java Web Start, so i found 
com.sun.javaws.IcoEncoder in Mustang sources. 

Secound there must be create a lib that can edit the windows 
exe resources. 

Maybe it is more simple to bundle NetBeans with some binary 
programms like windres to set the icon of a .exe.
Comment 1 Jesse Glick 2005-09-19 22:51:32 UTC
Not in 5.0. As you found, it is not easy to do. We have thought about various
options, including just replacing a fixed byte sequence in the *.exe file, but
have not had time to do anything yet.
Comment 2 rmatous 2006-02-24 10:48:36 UTC
*** Issue 70559 has been marked as a duplicate of this issue. ***
Comment 3 Jesse Glick 2006-07-11 23:59:22 UTC
*** Issue 79235 has been marked as a duplicate of this issue. ***
Comment 4 Jesse Glick 2006-08-23 19:06:16 UTC
*** Issue 83287 has been marked as a duplicate of this issue. ***
Comment 5 tomwheeler 2007-12-11 00:39:35 UTC
I need this in my build as well.  I am able to it with "reshacker" (http://www.angusj.com/resourcehacker/) during my
build, at least under Win32.  Still, I'd like a better way and preferably one that other people are using.
Comment 6 Jesse Glick 2008-05-14 20:35:04 UTC
*** Issue 118066 has been marked as a duplicate of this issue. ***
Comment 7 Jesse Glick 2008-06-04 17:08:12 UTC
*** Issue 136365 has been marked as a duplicate of this issue. ***
Comment 8 crosati 2011-01-04 10:27:02 UTC
I've found the following workaround (using NetBeans 7.0beta):

1. copy the ${harness.dir}/launchers/app.exe to <your-project>/application/launchers/app.exe

2. follow the instructions at http://wiki.netbeans.org/DevFaqExecutableIcon to change the icon of the just copied app.exe file

3. add the following to <your-project>/build.xml

  <target name="build-launchers" depends="suite.build-launchers">
    <antcall target="replace-windows-launcher"/>
  </target>

  <target name="replace-windows-launcher" description="Replace the Windows launcher exe">
    <copy file="application/launchers/app.exe" tofile="build/launcher/bin/${app.name}.exe" overwrite="true" failonerror="false"/>
  </target>
Comment 9 Antonin Nebuzelsky 2011-08-24 08:46:20 UTC
I don't see a reliable way of implementing this enhancement. None of the exe file icon modification utilities mentioned in the issue and in the FAQ is a component we would like to bundle with NetBeans. Also relying on the user specifying a path to separately installed utility is not the way to go. It is better to let the users follow the how-to in the FAQ which can be updated anytime in future.
Comment 10 Jesse Glick 2011-12-28 17:41:24 UTC
I asked on stackoverflow whether there is a suitable library out there.
Comment 11 Jesse Glick 2014-03-31 22:34:56 UTC
Someone mentioned http://pecoff4j.sourceforge.net/ which might work. Have not tried it myself.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo