Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 64380 - NPE from java.awt.Dimension.<init> on Win XP L&F with custom desktop theme
NPE from java.awt.Dimension.<init> on Win XP L&F with custom desktop theme
Status: RESOLVED WONTFIX
Product: installer
Classification: Unclassified
Component: Tools bundle
4.x
PC Windows XP
: P2 (vote)
: 5.x
Assigned To: mslama
issues@installer
:
: 61555 72954 74337 76233 77114 80655 84043 118032 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-14 21:04 UTC by fretful
Modified: 2007-10-10 06:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Logfile (27.05 KB, text/plain)
2005-09-21 19:35 UTC, fretful
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fretful 2005-09-14 21:04:35 UTC
I am able to launch the installer of Netbeans 4.1 but, when i am at the page
before any files are installed into the folder, the installation quits! if i
press the "next" button. Now there are no files in my folder! What the hell can
i do now?
Comment 1 mslama 2005-09-15 11:24:22 UTC
Please first check if your installer is not corrupted. There is md5sum on
download page.
Comment 2 Jan Chalupa 2005-09-16 08:40:27 UTC
Please provide more info. What installer did you try to run? NB IDE standalone?
NB + AS bundle? Also please check you have enough disk space on the drives where
you're trying to install to and where your system saves temporary files.
Comment 3 fretful 2005-09-21 16:45:04 UTC
i used the NB Ide standalone & NB + AS, i also tried the latest version 1.5
20.09.2005 but it dosen't work either


i got 5 GB free on my C: drive ^^

and temporary files are stored on C:/temp ^^

i installed jdk1.5.0_04 and the jre1.5.0_04.

 i got a win XP PC with service pack 2 , and the md5 sum is correct !
Comment 4 mslama 2005-09-21 16:51:07 UTC
Is there file install.log in $NBINSTDIR/_uninst dir? If yes please attach it here. 
Comment 5 fretful 2005-09-21 18:17:04 UTC
i just got a netbeans install dir, but there isnt any other folder in it, as i
said before my installation aborts when i see the summary where it will be
installed. the whole window just closes.
Comment 6 mslama 2005-09-21 18:44:44 UTC
There is another way: Start installer from console with -is:log <Log file name>
eg. -is:log a.log. It will create log file from native launcher. In this logfile
you will find location of setup.jar. Copy this setup.jar file somewhere. Then
you can Cancel running installer. Now start from console: java -jar  setup.jar.
This will start installer and log installer output to console. By this way you
could get more info. (Increase console buffer size.) Copy log from console to
file and attach it here.
Comment 7 fretful 2005-09-21 19:35:40 UTC
Created attachment 25049 [details]
Logfile
Comment 8 mslama 2005-09-26 10:39:03 UTC
I checked JDK sources. It looks something is broken. (Dimension instance passed
to Dimension constructor in provided call stack is probably retrieved as
property in
com.sun.java.swing.plaf.windows.WindowsProgressBarUI.getPreferredInnerHorizontal()
from XPStyle.) Do you use some customized theme? Could you try to use default
theme? Or Windows Classic theme?
Comment 9 fretful 2005-09-26 13:51:38 UTC
Well it worked, i used the classic theme --- and the installation completed

Thx alot ;)
Comment 10 mslama 2005-09-26 19:14:20 UTC
As it looks like Swing bug I would like to reproduce it somehow and file it
against JDK. Is there any way how to modify default XP theme to get this
problem? Or could you send me your custom theme? (Theme can be saved to file.)
Thanks.
Comment 11 mslama 2005-10-19 08:09:57 UTC
*** Issue 61555 has been marked as a duplicate of this issue. ***
Comment 12 mslama 2005-10-19 08:11:21 UTC
For this I already filed issue against Swing
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6337517. Workaround is to
switch to default desktop theme. Closing this as WONTFIX.
Comment 13 mslama 2005-10-19 08:12:21 UTC
Closing
Comment 14 mslama 2005-11-04 09:19:53 UTC
Please could you send me additional info I asked for last time? As it is not in
this issue description I repeat it here:
Do you use any tool to customize your "visual style" or "skin"? Or do you use
any custom skin? (Even if your theme file points to default msstyle file:
Path=%WinDir%Resources\themes\Luna\Luna.msstyles.) The question is this if your
default "skin" was modified anyhow.)

"The company TGTSoft makes a tool called StyleXP which can be used to apply a
different visual style on Windows XP. They also make StyleBuilder which allows
you to create and edit visual styles and save them to a .msstyles file which can
then be included in a theme.

Judging from the bug description, the user might be running with a custom visual
style. It could be one downloaded from www.themexp.org or one they made
themselves. What is the name of the theme file?"

Are you still able to reproduce problem with your original desktop theme?

Thanks
Comment 15 fretful 2005-11-04 13:37:41 UTC
Well i dont know which style it was cause i deleted it some years ago. and i
just remeber having one of these themes from www.themexp.org.  i didn't use any
extra tool just copied the themes and locked up windows to use them.
Comment 16 mslama 2006-02-23 18:05:42 UTC
*** Issue 72954 has been marked as a duplicate of this issue. ***
Comment 17 David Simonek 2006-04-27 16:01:34 UTC
*** Issue 74337 has been marked as a duplicate of this issue. ***
Comment 18 mslama 2006-07-10 13:38:55 UTC
*** Issue 77114 has been marked as a duplicate of this issue. ***
Comment 19 mslama 2006-07-24 15:04:11 UTC
*** Issue 80655 has been marked as a duplicate of this issue. ***
Comment 20 mslama 2006-09-13 09:39:35 UTC
*** Issue 84043 has been marked as a duplicate of this issue. ***
Comment 21 mslama 2007-02-07 15:59:47 UTC
*** Issue 76233 has been marked as a duplicate of this issue. ***
Comment 22 mslama 2007-10-10 06:41:47 UTC
*** Issue 118032 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo