Bug 6427 - External compilation do not go when compiling more than ten classes with a space in path.
External compilation do not go when compiling more than ten classes with a sp...
Status: CLOSED FIXED
Product: java
Classification: Unclassified
Component: Unsupported
3.x
All All
: P4 (vote)
: 3.x
Assigned To: Tomas Hurka
issues@java
: SPACE_IN_PATH
: 10484 10743 12201 12319 16463 24943 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-25 21:09 UTC by Jan Lahoda
Modified: 2007-09-26 09:14 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
javac commandline (1.59 KB, text/plain)
2001-07-20 20:32 UTC, Christoph Kutzinski
Details
compiler params (3.43 KB, text/plain)
2001-07-20 20:32 UTC, Christoph Kutzinski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2000-04-25 21:09:46 UTC
Get attachment, unpack it do C:/ and add filesystem "C:/Test Files",
and on the file system call Build All.
When in the directory name is not a space, or when compiling less than 10 files, it goes alright.
Comment 1 Svata Dedic 2000-07-13 08:50:59 UTC
It is OK at least on Linux/Solaris.
Comment 2 Marek Grummich 2000-07-25 09:21:59 UTC
Priority is changed to P4 (normal).
Comment 3 Christoph Kutzinski 2001-05-16 13:56:27 UTC
I also experience this behaviour. When I mount a filesystem with a space in it 
and add more then 10 files (with up to 10 it works) to the project and then 
build the project with the external compiler I get:

javac: invalid argument: C:\Program
Usage: javac <options> <source files>
where possible options include:
  -g                        Generate all debugging info
  -g:none                   Generate no debugging info
  -g:{lines,vars,source}    Generate only some debugging info
  -O                        Optimize; may hinder debugging or enlarge class file
  -nowarn                   Generate no warnings
  -verbose                  Output messages about what the compiler is doing
  -deprecation              Output source locations where deprecated APIs are 
used
  -classpath <path>         Specify where to find user class files
  -sourcepath <path>        Specify where to find input source files
  -bootclasspath <path>     Override location of bootstrap class files
  -extdirs <dirs>           Override location of installed extensions
  -d <directory>            Specify where to place generated class files
  -encoding <encoding>      Specify character encoding used by source files
  -target <release>         Generate class files for specific VM version
Errors compiling test.
Comment 4 Svata Dedic 2001-05-16 14:09:32 UTC
Can you reliably reproduce the problem ? If so, please attach here the exact
command lineused to laungch the IDE (modify the external compiler property to
begin with "cmd -c echo ", or capture the command in any other way) so we may
see whether the commandline is ill-formed or what. Please run netbeans with
-J-Dnetbeans.debug.exceptions=true and try to reproduce the bug. You'll find
trace messages about launching external process (compiler) - please attach them
here too.
Comment 5 Christoph Kutzinski 2001-05-16 14:40:22 UTC
I started Netbeans with -J-Dnetbeans.debug.exceptions=true, but not trace messages about starting the external compiler.
Content of my ide.cfg:
-jdkhome C:\Compilers\jdk1.3.0_02 -J-Xmx128m -J-Xss1024k -J-Xms32m -J-Dnetbeans.debug.exceptions=true

I create an attachement with the commanline.
Comment 6 Christoph Kutzinski 2001-05-16 14:43:01 UTC
Created attachment 1376 [details]
javac commandline
Comment 7 Christoph Kutzinski 2001-05-16 14:44:02 UTC
Created attachment 1377 [details]
compiler params
Comment 8 Svata Dedic 2001-05-16 14:57:48 UTC
One more thing, could you get here the file mentioned on the compiler
commandline with filenames (the one after @) ? The commandline seems OK,
properly quoted :-(
If you - with the same IDE setup - compile a single class does everything go
well ? Could you please attach a commandline from a single file compilation ? 
Sorry to bother you but I am kind of stuck and I want to get rid of this issue.
Comment 9 Svata Dedic 2001-05-16 15:05:08 UTC
Oops, I didn't look at the compiler params attachment. Now it is a little
clearer ;-) Could you please verify one assumption ? Try to compile as much as
possible classes so that the compiler is invoked with their names right on the
commandline instead in a separate file. If that is OK, add one more class (so
the file is created) and that should fail :-\
I suppose we have to quote the filenames EVEN if passed through the file. Stupid
windows, really.

Comment 10 Christoph Kutzinski 2001-05-16 15:22:06 UTC
With 10 files no compilerparams file is created and it works. With 11 files a compilerparams file is created and it doesn't work.
Comment 11 Tomas Hurka 2001-05-17 12:21:49 UTC
*** Issue 12201 has been marked as a duplicate of this issue. ***
Comment 12 Tomas Hurka 2001-05-22 15:27:15 UTC
*** Issue 12319 has been marked as a duplicate of this issue. ***
Comment 13 Svata Dedic 2001-09-12 08:25:26 UTC
It should work now for javac & windows. However, Jikes is broken - 
it tokenizes the filelist using a whitespace as a boundary and does 
not understand quoting/escaping in the filelist.

The bug is fixed *only* for Windows platform, I don't have a way to 
test it on OpenVMS. Jesse, could you give me a contact to Compaq 
people working on VMS issues ?
Comment 14 Jesse Glick 2001-09-13 22:56:16 UTC
Add mgarrison@netbeans.org to the CC list, or mail
netbeans@compaq.com.
Comment 15 Jan Becicka 2001-10-05 10:55:12 UTC
[200110050100] Verified
Comment 16 Svata Dedic 2001-10-11 12:53:12 UTC
*** Issue 16463 has been marked as a duplicate of this issue. ***
Comment 17 Svata Dedic 2001-10-11 16:50:26 UTC
*** Issue 16463 has been marked as a duplicate of this issue. ***
Comment 18 Jesse Glick 2002-03-25 04:13:35 UTC
*** Issue 10743 has been marked as a duplicate of this issue. ***
Comment 19 Jesse Glick 2002-03-25 04:16:07 UTC
*** Issue 10484 has been marked as a duplicate of this issue. ***
Comment 20 Jesse Glick 2002-03-25 04:25:04 UTC
Svata do you know what the correct target milestone for this bug is?
Also which files was it fixed in? Very commonly reported, so we ought
to have full information in this report.
Comment 21 Svata Dedic 2002-03-25 08:44:25 UTC
The fix was released with NB-3.3.0 according to CVS history.
Changed file:
/cvs/openide/src/org/openide/compiler/ExternalCompilerGroup.java,v
revision 1.35
Comment 22 Tomas Hurka 2002-07-01 16:58:44 UTC
*** Issue 24943 has been marked as a duplicate of this issue. ***
Comment 23 Tomas Hurka 2002-07-01 17:01:03 UTC
Reproduce on Mac OS X, see issue #24943 and I was able to reproduce it
on Linux too using the test classes from issue #24943. Reopening.
Comment 24 Jan Lahoda 2002-07-01 17:22:20 UTC
It does not work on Solaris too (using test case from issue #24943).
Comment 25 Tomas Hurka 2002-07-01 17:34:02 UTC
Fixed in trunk. All platform except VMS now uses quoting.

Checking in ExternalCompilerGroup.java;
/cvs/openide/src/org/openide/compiler/ExternalCompilerGroup.java,v 
<--  ExternalCompilerGroup.java
new revision: 1.46; previous revision: 1.45
done
Comment 26 Tomas Hurka 2002-07-01 18:00:56 UTC
Reopening, so I can set resolution to RESOLVED FIXED.
Comment 27 Tomas Hurka 2002-07-01 18:01:43 UTC
FIXED.
Comment 28 Jan Becicka 2002-10-15 11:55:52 UTC
Cannot reproduce in 200210090100
Comment 29 Quality Engineering 2003-07-01 13:20:00 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo