Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 64104 - Configuration files node not refreshed after adding web.xml
Configuration files node not refreshed after adding web.xml
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Web Project
4.x
All All
: P4 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
:
Depends on: 89479
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 10:33 UTC by Petr Jiricka
Modified: 2008-03-28 02:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2005-09-12 10:33:13 UTC
From a user, who attempts to import a web project which does not have WEB-INF
inside docroot. Looks like the config files node is not refreshed correctly.
Note that I did not try to reproduce this issue.


* My "webapp" directory doesn't contain a WEB-INF, which causes a message to
  pop up every time I do anything -- annoying!

* My descriptors are in a different directory -- can't see a way to add them
  to the "Configuration Files" tab.

* Manually create WEB-INF directory and copy descriptors (web.xml + lots of
  config files) across. Refresh all files and they don't show up in the
  "Configuration Files" section. Have to open web.xml from Files view.
Comment 1 Petr Jiricka 2005-09-12 10:35:02 UTC
Related to issue 64088 - happens in the scenario described in that issue.
Comment 2 Jaroslav Pospisil 2006-03-13 13:43:34 UTC
TM 5.0->TBD
Comment 3 Radko Najman 2006-07-26 10:10:29 UTC
Currently it is not supported to have placed web.xml somewhere else than in
WEB-INF under Web Pages.

Agreed that Configuration Files are not refreshed. It is not necessary to go to
the Files view, web.xml can be found under Web Pages node which is refreshed.
Comment 4 Radko Najman 2007-04-25 14:28:55 UTC
The first part related to the WEB-INF location has been already fixed (issue
#64088).
Comment 5 David Konecny 2008-03-28 02:58:09 UTC
First, the most important part has been fixed. Other two - no plan to fix them.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo